rewire problems

    Oct 02 2008 | 3:17 am
    Since reading about the new transport-rewire compatibility stuff I was anxious to try it out. Unfortunately, I keep getting confronted with "ad_rewire: error starting audio. Is ReWire mixer running?"
    I haven't played around with rewire in a while but I have gotten it to work successfully before.
    However, I have upgraded all of my software since then, including my OS.
    I've tried running Logic Studio 8.0.2 as a host and received the error. Aftwards, I re-installed Logic from the dvd and downloaded/installed the 8.0.2 update from apple again to make sure everything was in check. I still received the error.
    So I then tried using Pro Tools 7.4.2 as a host and received the same message. This makes me think that it is a problem with Max/MSP and not the software. The only other explanation I could come up with is some underlying driver that needs to be installed. However I was under the impression that the rewire drivers were automatically included with the rewire client/host software.
    I'm running Macbook Pro, OSX 10.5.4 1.83 GHz Inter Core Duo, 1.5GB 667 MHz DDR2 SDRAM

    • Oct 02 2008 | 5:01 am
      Sorry to hear that you can't get it to work.
      The Max/MSP ReWire audio driver (sitting in the ad folder) does not automatically get installed into the ReWire folder. It might help to get the latest one from 5.0.5 copied to the ReWire folder. But, since part of ReWire's vast tower of lameness is that the installers for various applications create ReWire folders in various locations, you might want to search for every ReWire folder you have and get rid of any old ones. That way you'll have a clue which one is running. Then make sure there's a Max/MSP driver in there.
      Also, I tend to always run the mixer app before launching Max/MSP. We mostly tested this stuff with Live (both Mac and Windows) and Logic. ProTools and ReWire together? Oof.
      David Z.
    • Oct 02 2008 | 6:35 am
      did you mean MSPReWireDevice.bundle?
      I'm not sure what to do. I tried installing the Rewire 1.7 package from the Propellerhead web site. Then I tried various combinations of having the new Rewire.bundle along with the MSPReWireDevice.bundle in the /Library/Application Support/Propellerhead Software/ReWire folder which included:
      Just having the Rewire.bundle in the folder Just having MSPRewireDevine.bundle in the folder having both bundles in the folder having neither.
      All of this seems to either have no effect or cause Max to say that it could not register ReWire or one time it made Logic go nuts without Max being open.
      In any case, that was the only folder I found to have a rewire bundle, but I'm not completely sure thats where Logic looks for its rewire files ?!?!?!?!?!?
      Anyway, thanks for the help. I'll probably end up going back to good old midi clock sync but I thought this could be interesting. On the upside, AES tomorrow!
    • Oct 02 2008 | 5:17 pm
      Occasionally rewire just barfs, in my experience.Mostly on Mac.
      The only way I've found to get it going again is delete everything in
      ~/Library/Application Support/Propellerhead Software/ReWire/
      or the whole propheads folder if you like
      reinstall rewire 1.7
      Start max, select rewire or switch on DSP until you see the "registering.." message, quit max, restart, start your host, etc.
    • Oct 03 2008 | 2:26 am
      Andrew - Thanks! I followed your instructions exactly and the rewire voodoo worked. Weird!
      So now for the next question- what are the commands I can use to make transport's clock source be rewire?
      If I give transport the getclocksources message, it dumps 'append rewire' out the rightmost outlet. However when I try sending 'clocksource rewire' message, the transport reverts to internal. The same thing happens when I try to change it through the inspector.
      Here is the really weird part- When I send a bang to the transport, it outputs the current song position info from Logic
      .....Ok its around 30 minutes later. I found that turning audio on and off seems to get things running. transport still says internal but it seems to be connected to rewire.
      I found that I need to re-instantiate the metro object for it to output bangs if it is synced to the transport. Sometimes I have to do this if I change something in the dsp chain.
      Here is the patch I'm using to try all of this. I'm not even going to get into the timing problems in rewire when metro actually works.
      I hope I dont sound like I'm complaining. I'm just trying to help point out any problems in this new system. I do really appreciate that the higher-ups at Cycling 74 are willing to personally respond to my rewire problems!
    • Nov 20 2008 | 12:05 am
      Hi guys,
      I have troubles with rewire too. I work on Mac OS 10.5 and i want to use Live and Max in rewire (Live master / Max slave).
      When i start Max i have the "register..." message. I have "Max/MSP" in the "Audio From" combo box of each track in Live. But when i try to switch audio on in Max i always have "ad_rewire: error starting audio. Is ReWire mixer running?" and audio stays off.
      I tried what Andrew Pask adviced but it's still the same. I re installed several times rewire 1.7, i tried with Live 6 and 7, i checked that the "Application Support/Propellerhead Software/Rewire" folder is the only Rewire folder of my computer... It always worked with Max 4, Live and Reason but only Max 5 doesn't work, so i think the problem comes from Max 5.
      What can i do? Please help, i really need rewire...
    • Dec 01 2008 | 2:18 am
      Just to throw this out there ... but I was running into this also when I tried to select ad_rewire and turn the audio on. I found that I actually had to start the given host first (in my case live) which I assume starts the rewire mixer, then the selection of ad_rewire worked for max.
    • Dec 05 2008 | 1:53 am
      Having the same problem with Logic and Max. I've gone through all the suggestions and have never had this problem in the past (first time trying to get this to work in Max 5 though).
      The most frustrating part is if I make a rewire~ object I get the error "Another ReWire Mixer application is already running", but of course if I try to turn on the audio or use hostsync~ I get "ad_rewire: error starting audio. Is ReWire mixer running?"
      I know this should be straight forward, but if anyone has any more suggestions I'd really apppreciate it.
    • Dec 05 2008 | 10:35 am
      I finally solve my problem. The Rewire folder which is used by Live and Max is not "Macintosh HD/Library/Application Support/Propellerhead Software/ReWire" but "[user]/Library/Application Support/Propellerhead Software/ReWire". So you need to place your MSPReWireDevice.bundle in this folder (in your personnal account).
      I hope this can help.
    • Dec 08 2008 | 10:26 pm
      Thanks for the reply,
      I've tried every combination suggested here though and nothing is working. I'm beginning to think that this might be a problem with Logic. Does someone know of a free app that I can test ReWire connectivity with Max just to test this theory?
      Cheers, Ethan
    • Dec 08 2008 | 10:29 pm
      the rewire~ object turns MaxMSP into a mixer application, which is why you are getting the error about there being 2 mixer apps.
      You probably want to select ad_rewire in the DSP status window to turn MaxMSP into a synth app to get it working with Logic.
    • Dec 08 2008 | 10:45 pm
      Hi Andrew,
      I was just using my woes with the rewire~ object as an example that neither route was working (host or slave). What I really want to get working is hostsync~ between Logic and Max.
      Like I said I think I've exhausted every combination of installing rewire, placing it in the "correct" folder, starting Max or Logic first, setting up Logic environment, etc. Not sure what else to try except making sure that Max can sync to any generic Rewire device... do you know of a free one I can try?
      I moderate a software forum myself ( so I completely understand the tendency to disregard certain user's posts as inconsequential, but I've spent a few nights of free time trying to solve this and I'm pretty sure it shouldn't be this difficult.
      Seriously appreciate any feedback, Ethan
    • Dec 08 2008 | 11:50 pm
      If I use Logic 8.02 and MaxMSP 5.05, and follow the instructions in the Logic manual which are to do with setting up an Aux track in the mixer, it all works fine, hostcontrol, hostsync~, the lot.
      The host* objects are designed to be used in conjunction with the ad_rewire audio driver.
      Beyond all the reinstalling crap I mentioned earlier in this thread, I'm not really sure what to add.
    • Dec 10 2008 | 12:50 am
      If it's only hostsync~ that you need, I made a simple hostsync~ like message sender that allows you to send bar/beat etc. information between applications without needing to set ad_rewire as your audio driver.
      It's a VST plug, available here:
      I've only tested it with Cubase, no idea if it will work with Logic.
    • May 25 2009 | 4:22 am
      This plug rocks. Combined with Soundflower or anything like it (I actually use the interface of my RME Fireface 400 to do the job) it allows you to receive Sync without losing Max's Audio inputs. I just tried it with Live 8 and it is quite perfect and very easy to use. I highly suggest it to all the people who are looking for a way to sync without the inconvenients of Rewire or even sync~...
    • May 25 2009 | 10:19 am
      Plugin has been updated to fix a couple of things and retrieve some other useful info from your host.
      Simplified URL is:
    • May 25 2009 | 5:05 pm
      Thanks for this. It looks extremely useful.
    • May 26 2009 | 12:08 am
      To fix the "ad_rewire: error starting audio. Is ReWire mixer running?" problem you don't need to delete any files...
      Just go into DSP status and re-set the rewire channels that you had set before, as max tends to forget them (i posted a thread about it ages ago... no replies).
      Also, I'd recommend steering clear of rewire midi in max because its a bit crap, as in:
      me - ummm... there was supposed to be a note off there! maxmsp - note off? what note off? i detected 2 note ons... on the same key, but no note off! me - ...thanks for nothing you useless piece of #$%&. *cue keyboard cat*
    • May 30 2009 | 1:42 pm
      I think i hate rewire now.
    • Jun 08 2009 | 10:53 pm
      So if you use rewire ( if your lucky to make it work) the audio is one way only (from max >>sequencer) how to you input sound into max msp when rewired? via a vst upd audio streamer plugin perhaps?
    • Jun 08 2009 | 10:54 pm
      OSynC for xp would be nice too !!
    • Jun 12 2009 | 2:10 am
      I just built a version for Windows. I have not tested it at all.
      Let me know if it works
    • Jun 13 2009 | 6:00 am
      hi OSynC looks nice
      i load the msp patch and insert the plugin fine, but i get a mesage ,
      "there were 3 errors loading this effect"
      i have max 5 and also i beleive pluggo as i have lots of pluggo plugins on my nuendo insert list.
      i shall keep trying.
    • Jun 14 2009 | 3:11 pm
      Don't insert the plugin into a Max patch, it should be loaded into a ReWire-compatible host, like Nuendo.
      The included .maxpat file is used to catch the transport information coming from your host sequencer.
    • Jun 15 2009 | 2:21 am
      hi :)
      i did load the plugin in nuendo and opened the msp patch. no worries I shall try again either tommorow or the day after. when i have a time . it looks real nice , just needs me to be more focused in front of the machine. most likely my fault, i shall try again soon. :p
    • Jun 15 2009 | 3:49 am
      hi i thought id give it a go this early morning.
      i noticed i needed pluggo runtime on your webpage ,so i installed that. now instead of 3 errors i have only one error when inserting the osync pluggin into nuendo.
      " there was one error loading this effect" ( it says this on the osync plugin-the yellow message area)
      i have the patch loaded in msp and nuendo open with the plugin inserted on a mono audio channel ...i click play and there is no bang in msp (playing )or bar count etc.
      ive reloaded the plugin. any ideas?
      im using nuendo 3 and msp 5.
    • Jun 15 2009 | 4:07 am
      i noticed on the 'view - osync' page of the vst plugin that the bars/ beats where it looks like it is sending out on udp 10101
      so i closed max msp and loaded up oscmonitor.exe and monitored on 10101 but there are no osc messages being sent fron the plugin it seems.
      it must be the vst plugin not sending out osc messages. ..maybe i'm missing something , quicktime? java? not sure.
      as a side note, as i noticed you were interested in requests for future updates, i was looking for a way to trigger nuendo to start and locate from msp. Do you think osync would be able to do the reverse and control a sequncer from msp in the future?
    • Jun 15 2009 | 4:23 am
      Ah, I think I know what the problem is. I'll fix it and get a new version up over the next couple of days.
      The bi-directional control is a good idea, something I have also wanted to do. I'll see if I can add that.
    • Jun 15 2009 | 4:27 am
      that would be great . as rewire steals our audio channels,lol. rewires our audio away from us :p
    • Jun 24 2009 | 8:19 am
      i had the same problem with rewire: not being able to start it, the dreaded "is mixer running" question. i found out, that my max5-folder had weird user-rights, because it was set to read only. changing it back to read/write, restarting finder the host app and max/msp seems to have fixed this.
      just in case somebody else experiences this problem
    • Jul 09 2009 | 6:30 am
      X37V wrote on Sun, 14 June 2009 22:23Ah, I think I know what the problem is. I'll fix it and get a new version up over the next couple of days.
      The bi-directional control is a good idea, something I have also wanted to do. I'll see if I can add that.
      Hi X37V
      did you manage to find out what the problem was?
      teqy :)
    • Jul 09 2009 | 11:22 am
      My problem went away when i did get info for the max folder and gave everyone read write permission.
    • Jul 17 2009 | 2:29 am
      Hey teqy,
      So sorry for the delay - the fixed build for XP (0.3.1) is now up.
      I'm working on a slightly updated version which should be out soon, but this will at least give you an idea of how OSynC works:
    • Jul 18 2009 | 2:04 am
      cool ,i shall give it a whirl next week when i'm back on my msp machine. ive been experimenting with oscglue recently its pretty cool! includes osc timeline/code data from sequencer to msp.and vst > osc sliders aswell.
    • Jul 21 2009 | 1:05 pm
      Hey Mr X37V, I have been trying your OSync v.0.31 on a PC (the Mac version is great) with Live 8, but can't get to receive anything in the 10101 port. Same Max Patch on PC and Mac, only the plug changes from Mac to PC. Do you have any idea?
      Thanks for this, it has helped me SO much. I'll be posting a video soon of what I'm doing live on my death/electronica/breacore band WHOURKR. Built the patch on Max, using a Monome for the vocals and the guitars... The only thing I missed was a way to synchronize the whole thing while making the sound go both ways - so no Rewire. Thank you again!
    • Jul 21 2009 | 1:51 pm
      Hey Yann, cool man, glad the plugin is useful. Gotta start with a dumb question. Do you have CNMAT's [OSC-route] object in your Max search path in Windows? (A [route /fraction] etc will also work.) If so, does anything come into 10101 at all if you attach a [print] to the [udpreceive 10101] object in Max?
      When I built it last week it was working with Cubase 4 and Max 4 (as well as Processing) in XP. Sadly I haven't checked it in Ableton under Windows.
      Are there any errors in the plugin window, when you add it in Ableton (when you look at the plugin in 'Parameters' view)?
    • Jul 27 2009 | 2:01 am
      hi :) just about to try it out ( osync)! :) I shall post back tomorrow when i'm back on the net.
    • Jul 27 2009 | 9:52 pm
      X37V wrote on Tue, 21 July 2009 07:51Hey Yann, cool man, glad the plugin is useful. Gotta start with a dumb question. Do you have CNMAT's [OSC-route] object in your Max search path in Windows? (A [route /fraction] etc will also work.) If so, does anything come into 10101 at all if you attach a [print] to the [udpreceive 10101] object in Max?
      When I built it last week it was working with Cubase 4 and Max 4 (as well as Processing) in XP. Sadly I haven't checked it in Ableton under Windows.
      Are there any errors in the plugin window, when you add it in Ableton (when you look at the plugin in 'Parameters' view)?
      >> OSynC
      Hi, worked a treat . to make it work in nuendo you need to manually enable the plugin in the plugin section ( devices menu i think?),then you can see it on the insert drop down menu of each input channels/groups etc. (also pluggo runtime is needed. which is available on the cycling74 website.
      yep so i did that and it worked....looks very stable and neat , (no errors reported in the plugin window.) whereas before i think I had 3!?
      so what ever you did = fixed it on Steinberg and xp pro, great job!
      p.s cool name too ( OSynC) lol .
    • Jul 08 2011 | 3:07 pm
      hey i know this has changed topic a bit - but i had this issue and fixed it by ensuring that i has the msprewire.config file in the Applications/Max5/Cycling74/ad
      it worked then without an issue.
    • Dec 04 2015 | 3:27 pm
      Hi X37V. Great stuff. Do you think it would work in logic9 with the fxpansion vst wrapper?