routing audio internally in max for live

    Jun 25 2018 | 7:54 pm
    I want to be able to use a send~ object to send audio to another maxforlive plugin. My initial attempt does not seem to work. Is this allowed in maxforlive?

    • Jun 25 2018 | 8:21 pm
      send~ and plugsend~ are not supported. did you try the non-msp send and live.send yet?
    • Jun 25 2018 | 9:33 pm
      There seems to be no live.send
    • Jun 25 2018 | 9:45 pm
      Upon further investigation, I found that fixed name send~ does not work. Fixed name control send DOES work. Dynamic naming of send~/receive~ and send/receive does not work. Can someone please confirm that this is the expected behavior in MaxForLive or is this a bug?
    • Jun 26 2018 | 9:05 am
      @Anthony I'm quite new to Max For Live. What do you mean exactly by "Fixed name control send" ?
    • Jun 26 2018 | 1:37 pm
      It means when you instantiate the send, you give it a name. As opposed to dynamically setting the name with the "set" command.
    • Jun 26 2018 | 5:06 pm
      According to the reference page [send] doesn't understand a "set" command. Dynamic name setting can only be done with [forward].
    • Jun 26 2018 | 8:20 pm
      I always forget that [forward] exists and use the message box with semicolon syntax instead (the reference page for [forward] has an example of that).
    • Jun 27 2018 | 1:59 am
      same here, i usually try to "set" [s], then remember. one could do it with buffers in live. it also works halfway using tapin~ send foo receive foo tapout~
      halfway because you must restart DSP when it is loaded in the wrong order. while buffer with peek will add lot of latency, tapout has only one vector latency but therefore truncates possible 64 bit audios resolution.
    • Jun 27 2018 | 2:05 am
      anthony maybe we should combine our confusions and use the "set" message with live.send? :)
    • Jun 27 2018 | 2:45 pm
      Originally I was speaking about routing audio within MaxForLive. Audio send~ does indeed support the "set" command. This works very well in Max but not in MaxForLive. Control [send] does in fact not support "send", so I would definitely want to use [forward].
    • Jul 04 2018 | 2:53 am
      hey, you can't really use send~ and receive~ per say, but you can use Ableton Live's routing features especially if you're using Live 10: you could send audio to a [plugout~ 1 2 3 4 5 6...] and then receive multi-channel on different tracks, and then select which audio channel you need. It's not as straightforward as the send~ and receive~ but it works! hope this helps