scheduler stops for no reason! [edit]


    Dec 26 2010 | 2:15 pm
    EDIT:
    Whatever I wrote earlier is irrelevant. I noticed that no matter WHAT patcher I try to open, whenever I press a DOT on the keyboard (whether inside an object, or the patcher is locked or even in presentation mode) I get the error:
    "Choose Resume to Restart Scheduler"
    Can anyone please help me out? It's driving me nuts, as NOTHING appears in the Max Window. If I Resume the scheduler, and then press . again, it happens again and again and again, regardless of which patcher I open, even if I open some of the Cycling '74 patches from the [examples] folder..
    I am running Max/MSP 5.1.6 on Snow Leopard, MacBook. I have to note that I had never encountered this error before upgrading to Snow Leopard a couple of days ago, maybe that's got something to do with it?

    • Dec 26 2010 | 3:36 pm
      ok - it even happens if I have NO patcher loaded: I just load MaxMSP, then I press a dot, and I get that message. If I press Cmd+R to resume the scheduler, and I press the dot again, it happens again.
      I found out that I can disable stopping the scheduler, but I am not sure how wise that is - will it cause any problems?
    • Dec 26 2010 | 10:05 pm
      Pressing command+. disables the scheduler. This has been a feature for a very long time. Since Max 5 however you can disable the shortcut in the Preferences->Debugging->Disable Scheduler Stopping.