seq object + read midi files

    Jul 24 2013 | 11:04 pm
    Hey all,
    I'm trying to get the seq object to read in midi files directly from a umenu object. Instead it always opens the file dialogue and asks me to choose the file. I tried the full path as well as the relative path from the folder my max patch is in.
    Secondary problem is that the folder object keeps giving me the error: not a folder. even when it is clearly.
    I tried the detonate object and it reads in my midi files directly but the problem is I wanted to do dynamic tempo changes and thats pretty easy with seq.
    I know these are silly problems, I just cant for the life of me get these simple things to work.

    • Jul 24 2013 | 11:53 pm
      it's not a silly problem, just a max problem (most max problems are silly).
      you need to have the entire file path in the umenu, otherwise seq doesn't know where the file is. here's a way to do it:
      if you don't want the entire file path in the umenu, you can use a coll to associate a file name with its path, so the umenu outputs the name into a coll which is used as an index to the full path
    • Jul 25 2013 | 6:05 pm
      I already tried the full path. Still not working... message box says:
      read untilted:/users/name/etc/etc/foo.mid ----> seq object
      it just opens the file dialogue all over again.
      Also my folder object is not accepting folders. It keeps telling me error: not a folder when it definitely is a folder.
      Im starting to think max just doesnt want to recognize any of my path names.... anything that has to do with file paths has been giving me trouble lately.
      thanks for the coll tip
    • Jul 26 2013 | 3:34 am
      I think you're just dragging a file to the dropfile that's attached to the folder object, instead of a dragging a folder-- it needs to be a folder enclosing the MIDI files you want to open, then access the paths via the umenu... but if you are actually doing that, then I don't know-- you might need to contact c74 about it