"set current_input_sub_routing" problem


    Apr 23 2010 | 3:31 pm
    I've built a patch that populates a umenu object with the available sub routings and from which I can change that property on 8 tracks at a time. Choosing "1/2" from the umenu works (the center output is sent to a message reading "set current_input_sub_routing $1", then to a live.object, and it changes the property in Live), but when I choose either "1" or "2" i get an error in the max window reading "invalid syntax". So "1/2" works, and "1" and "2" do not. WTF?
    I've tried converting the message to a symbol (via tosymbol) but that does not change the behaviour at all. I've also tried some random formats of the "1" and "2" such as "1/" or "1." but none of that works.
    Help?

    • Apr 23 2010 | 5:29 pm
      an example patch always makes it easier for others to help
      -A
    • Jun 11 2011 | 11:16 pm
      Hi AMRAyw. I have the same problem with my saffire pro 24 soundcard. Live recognize 1/2 , 3/4 , 5/6 , but not 1 2 3 4 5 6!
      Have you solved your problem?
      the only thing i've noticed is that if you write just 1 you get a "syntax error" if you try tu put something like 1/1 or 1/0 (trying to reproduce the same syntax of 1/2) you get " The given IO target must be one of the available ones!"
      weird uh?
    • Jun 12 2011 | 11:10 am
      Post your patch and we may be able to help...
    • Jun 12 2011 | 12:10 pm
      maybe check your output channel config in Live's preferences to make sure your mono channels are enabled?
      works fine here setting stereo or mono channels with live.object.
    • Jun 12 2011 | 12:48 pm
      ok , I don't know how to attach a clipboard file so , this is an image of the patch.
      my input/output routings live preferences are correct (i suppose).
    • Jun 12 2011 | 5:23 pm
      Your patch looks correct to me. Note however that the object initialization happens only when you save and close the patch.