sfplay~ doesn't play

    Mar 09 2012 | 3:56 pm
    Hi i have a huge patch in which i use 4 sfplay~ for playing 6 ch files. (which are 16 bit and not heavy at all) quite often one of this sfplay~ doesn't start, it actually start but then it stop after a fraction of second,then after some stop start it can happen that it start playing, but usually when one of my sfplay get crazy after some time also the other start not to work. randomly i get sfplay disk error -51 (actually it's not always 51, sometime 36 sometimes other number) but not always, sometimes just doesn't play max 6.0.4 snowleopard

    • Mar 09 2012 | 4:57 pm
      Sounds like a buffer size problem. Check sfplay~.maxhelp -> "More features" -> buffer_size and try some sizes... There are already a couple of topics about this on this forum. Beware: if you also use sflist~, I think the sizes in sfplay~ & sflist~ have to match (or is it a Max 4 only limitations?)
    • Mar 09 2012 | 8:48 pm
      In Max 5 I have experienced situations in which the file (10 channels, 16 bit) would play if there would be a short time between opening and playing the file and it would not play if there would be a long time (for example >5 min) between opening and playing. I have tried different buffer sizes but it didn't solve the problem. At a certain moment I've stopped narrowing down the problem and solved the problem by always opening the file before playing it. I haven't tried if there is a difference between Max 5 & 6 yet. Oh and yes 'put hard disk to sleep when possible' was set to off in the system preferences.
      I'm curious to hear other peoples experiences since I'm not absolutely sure about the details of what I've experienced
      Edwin OSX 10.6.8 and in this case Max 5.1.9
    • Mar 10 2012 | 1:28 am
      i've had lots of similar problems with sfplay~, sfrecord~ and large and/or multichannel files, as have lots of other people on the forum.
      If you can fit the files into memory, you might be better off doing it that way. Alex Harker's ibuffer~ objects can help to save memory usage, since they don't convert the samples to 32bit.
      ---- Endless Series v3 out now - A unique synthesis and effect plugin/app based on the Shepard Tone auditory illusion. 30% off in March http://www.olilarkin.co.uk
    • Feb 04 2013 | 1:44 pm
      Here's a note I made to myself for a piece back in 2006. Might no longer be applicable but it certainly solved my problem back then:
      "Some Macintosh computers have trouble playing such [4-channel AIFF] soundfiles: they may simply stop playing at some point. A workaround is to build in an sfplay~ object in loop mood that plays continuously throughout the performance but whose output is not routed anywhere."
    • Feb 14 2013 | 5:26 pm
      Update: the colleague whose machine I was using in the performance with dodgy sfplay~ results repaired disk permissions, after which all problems disappeared. Not a scientifically verifiable solution but might help some of you out there.
      Best, Michael
    • Nov 29 2013 | 3:04 pm
      I was having this exact problem, but seem to have solved it. I was was using sflist~ as well as 5 instances of sfplay~ playing 8-channel files. After some experimentation I ended up using a buffer size of 20160 * 8 * 5 = 806400 in ALL FIVE splay~s AND IN sflist~ (if you don't have the same buffer in sflist~ as splay~ many problems can result)
      Hope that helps Andrew