sigmund~ for windows

    Sep 21 2010 | 7:34 pm
    sigmund~ is a great external. The problem is that it's only for Mac, or for PD. I'm using Max/MSP in Windows. Is there anybody here who has the time, will and skills to compile a windows version of it? I guess that a lot of people really want this!

    • Sep 22 2010 | 7:48 am
      let me give in another vote for this!
      also, i don't want to be too greedy but... it would be great to see [sc3~] and [ppiano~] for windows as well.
    • Sep 23 2010 | 8:23 pm
      +1000! would be really great to have those osx only stuff on windows as well. does those externals contain any osX specific code? if not could be not so difficult to compile sources for windows
      any comment from the developers?
    • Oct 05 2010 | 12:29 pm
      are the sources of sigmund~ available anywhere?
    • Oct 05 2010 | 2:38 pm
      You don't know how many times I have checked the website for a windows version, each time disappointed.
      If anyone knows who owns the source code, please tell them that I will pay THEM money to port it to windows, and do it for them!
    • Oct 16 2010 | 5:31 pm
      sigmund~ source code is available in the pd source package on miller puckette's site ! I had a quick look at it and there's max/msp glue in it. So it shouldn't be a problem to compile it on windows.
    • Nov 19 2010 | 6:29 pm
      Hey, I'm trying to build this on Windows in Visual Studio 2008, but - to be perfectly honest - I've no idea what I'm doing. So what I've done is download the Max SDK then opened the 'simplemsp~' example and literally copied and pasted the sigmund~ source code over the simplemsp code, then renamed all the files to 'sigmund~'.
      Here's what happened when I tried to compile it: First of all it came up with an error saying 'fatal error C1083: Cannot open include file: 'alloca.h': No such file or directory' so I commented out the part that included it. After doing that it seems to be compiling for a while (albeit with loads of warnings) but then stops with an error message saying 'LINK : fatal error LNK1104: cannot open file '.sigmund~.def''
      Anyone know what's going on? Any help would be awesome, because I really, really want this external.
    • Nov 21 2010 | 7:52 pm
      I'm not a C dev, but really hope someone help you and that this window version is going to come out, because sigmund~ is simply one of the greatest objects in max. (I'm on mac, but the day i'll need more power, The avaibility of sigmund~ on PC would be an argument for me to consider buying a PC.)
    • Nov 23 2010 | 5:54 pm
      Cheers, I'll have to try those things out. I'll let you know whether it works or not!
    • Nov 24 2010 | 7:56 am
      I just had to convert for Windows some of my externals (with Visual Studio Express 2010) - here are the steps I followed:
      - copied an example project (say, simplemax), opened it in VS, did the automatic conversion, closed the project.
      - added myext.c to the appropriate folder, and threw away everything but it the .sln, .vcxproj, .def, .filters and .user files, and renamed them with the name of my external (e.g., "myext.vcxproj" etc).
      - opened them in a text editor (I recommend Editpad Lite) and replaced all the occurrences of "simplemax" with "myext". Now you can re-open your solution in visual studio and everything should be at the right place.
      Unfortunately, Microsoft C adopts a quite strict c89 standard, which means that some things that work fine in gcc/xcode may not work in vc - nothing that can't be easily fixed, but if the code is long it can become quite boring. You can overcome the problem by setting the language to C++ in the project preferences, but this may cause other issues, so eventually I didn't.
    • Nov 28 2010 | 2:10 pm
      DONE IT!!! Woot woot! I just needed to make a .def file and include the FFT routine from PD. Here it is:
      Let me know if you have any problems.
    • Feb 15 2015 | 4:32 pm
      Is this available somewhere else? The link is bad now.
    • Jul 21 2017 | 6:18 pm
      Found a version here, haven't tried it yet though: