split sfrecord~ multichannel file to single wavs.


    Jul 26 2012 | 10:04 am
    hi, i've recorded a 10 channel audiofile with sfrecord~ and cant seem to split it back to single mono WAV files again. I've already searched the Forum and didnt find a solution that worked for me. so here's the problem: I've recorded the file using the "open soundfile.wav wave" message to "sfrecord~ 10" and a toggle that starts the record. sfplay~can open and play the file without problem. any other programm cant, saying its not a valid PCM format. (maybe due to 10 channels?) So splitting it via the "De-Interleaver" ect. is no option. then i've tried to manually record all the 10 outputs of "sfplay~ 10" with 10 single "sfrecord~ 1", with the result that sfplay simply stops playback after some 10-30 Sekonds. Im recording on a MacBook Pro 2.7 Ghz Intel Core i7 the a the built-in 500GB 5400rpm harddrive. any ideas?

    • Jul 26 2012 | 11:32 am
      I use Pro Tools for this - simply importing multichannel files will split them into their individual channels. Sometimes it tries to be clever, like insisting a six channel file is a 5.1 file, but otherwise it works fine, Cheers Roger
    • Jul 26 2012 | 12:12 pm
      hi roger, unfortunately i dont have protools, i tried to open the file in logic wich didnt work, tried to open it with the De-Interleaver (http://www.birmingham.ac.uk/facilities/BEAST/research/mulch.aspx) wich didnt work, tired to open it with Quicktime, Snapper, Audacity ect. all didnt work. The only thing that seems to be able to read the audiofile is the sfplay~ object in max. the only pssibility wich seems to work is to record every channel separatly in realtime with sfplay and one sfrecord (when using several sfrecords it just stops playback after some time) and that would take much too long. (4 10channel soundfiles, each about 24 Minutes ~ 960 Minutes.... .. ... . . ... ) there must be another way... i hope..
    • Jul 26 2012 | 1:43 pm
      or is there a limitation to sfrecord on how much it can record at once? it seems to always stop at a filesize of about 136mb when trying to record with two sfrecord objects at once...?
    • Jul 26 2012 | 10:06 pm
      finally found a solution - for mac users at least: http://www.audiofile-engineering.com/waveeditor/