stack underflow error in Andrew Benson's Recipe 43

    Feb 16 2013 | 4:28 am
    Hey all,
    For some reason, after about a minute of continuous rendering in Andrew Benson's 43rd recipe "AnaglyphRender" I get the following error messages repeated in the Max window ad nauseum: error binding fbo: GL Error: Out of memory error unbinding fbo: GL Error: Stack underflow
    I don't understand exactly what's going wrong, or what "stack underflow" could possibly mean. I've posted the patch along with a patch that just creates a couple objects to be rendered in 3d. The former has a not-yet-functional recording subpatcher that wasn't in the original...thanks for your help!!
    [mod - removed uncompressed patch]

    • Feb 16 2013 | 3:13 pm
      First: please use Copy Compressed… when copying a Max patch to the forum. This is explained in a sticky if you haven't worked out how to do it. For readers, having to scroll through thousands of lines of JSON code (what's worse, incomplete JSON code) is a royal PITA.
      Second, the error before the stack underflow is more to the point: Out of Memory. OpenGL ran out of memory. I'm not sure why, but I can't (and won't) investigate unless there's a complete compressed patch to look at. Someone else may have more experience with this particular tutorial to say something concrete, but given how little you're provided to go on, that's not actually likely.
    • Feb 17 2013 | 1:56 am
      Many thanks and many apologies! here is the compressed patch
    • Feb 17 2013 | 1:58 am
      The problem occurs with any objects I've tried; here's a couple to test it with: