Standalone Application under 5.0.6 (mac)

    Jul 18 2010 | 6:44 pm
    I've sent my standalone to a bunch of friends (also mac), none have been able to open it (nothing happens at all).
    after having followed the instructions taken from this forum, I've managed to relieve my max window from failure notes (concerning & jit.openexr in my case), BEFORE letting my friends try it out, that is:
    --Build your application without including any shaders or frameworks in the build script. --Go to your application and select Show Package Contents. --Copy Cg.Framework from /Cycling '74/jitter-externals to application/Frameworks/ folder --Copy shader files into application/support/ folder --Be sure to also include any shader files that the included shaders depend on. For example, many of the included image-processing shaders rely on one of the "passthru" vertex shader programs that reside in jitter-shaders/shared/ --include the jit.openexr.mxo external in your support folder as well
    so there seems to be no problem.
    what else could I have missed on?
    here he is, for test purpose, webcam autostart (51MB as an app, the fella):

    • Jul 20 2010 | 12:29 am
      Just curious, did you share it as a .zip or .dmg?
    • Jul 20 2010 | 1:00 am
      ehm, as an .app
      built the application & sent it.. not a good idea?
    • Jul 20 2010 | 1:27 am
      Dave raises a good question. Did you send it via the Internet as an app? If so, the file handler on the recipient's computer may have not known what to do with it and rendered it unusable. If you are sending it via the Internet, compress it into a zip or dmg as Dave mentions.
    • Jul 20 2010 | 8:12 am
      of course.. in this case I used dropbox, of which I don't know how it would deal with an app like this
      I'll give it a try. thanks for the notice!
    • Jul 20 2010 | 8:46 am
      Hi, just to confirm, under 5.0.5, a runtime patch opens native objects and ui as [bogus] on my friend's computer. But works fine with latest runtime.
    • Jul 20 2010 | 9:19 am
      you must zip your application before sending it with dropbox (dropbox do not preserves application's ressource fork)
      (maybe lattest dropbox beta 0.8.x has solved this problem... not sure.. last time I tried, Max standalone in a shared folder used to crash on launch)
    • Jul 20 2010 | 9:25 am
      thanks a bunch.. just dropped it off, waiting for friends' responses.
    • Jul 20 2010 | 1:44 pm
      hey everyone,
      you were right with your assumption.. works fine once offered to others in a compressed version. (and again, I'm one bit smarter than yesterday)