Standalone building issues

    Feb 04 2013 | 7:40 am
    Hi all,
    I have some outstanding build errors when building standalones in Max 6 (OSX).
    The following keep coming up each time I build:
    mxj_exec_wrapper: no such file in collective jit.matrix: no such file in collective pattr_obex: no such file in collective
    Having searched google and forums I see that people have had similar issues but nothing seems to be resolved regarding these just yet, or am I missing something?
    Have recently resolved some issues regarding the standalone being able to access java files (mxj and the like). This was resolved by adding BOTH the Cycling '74/java and Cycling '74/jsextensions folders to /App (Package Contents)/Contents/support.
    Just the three error messages above now outstanding.
    Anyone solve these?

    • Feb 04 2013 | 4:03 pm
      Hi Ben, You can try to include them in the build window by pressing include file or patcher. Do this for every file that's missing. For example: include "kansea:/Applications/Max6/Cycling '74/msp-externals/receive~.mxo" Also you can include a whole folder. Hope this will help.
    • Feb 23 2013 | 8:09 am
      Hi Giorgos, My Apologies I didn't seem to get an email notification of your reply! Coming back to this I found that I have no more issues after adding the folders I outlined above. Not sure why it wasn't working at first. Thanks, Ben
    • Feb 25 2013 | 2:49 am
      How did you solve the pattr_obex issue? I had the very same problem and it meant changing my pattr system to presets, which took awhile and made me ever so grumpy...I looked for "pattr_obex" file to include manually, but nothing came up...
    • Feb 25 2013 | 5:54 am
      Hi seejayjames,
      To be honest this issue seems to have resolved itself. I had anumber of build issues I was dealing with, some of which were solved through the inclusion of both the java and jsextensions folders. Initially this did not resolve the above problem, however it seems to have vanished now. I have however recently re-built my standalone without including these folders, and the issue is not there anymore. Weird.
      I'm sorry I can't be more help - have you tried adding these folders?
    • Feb 25 2013 | 6:10 am
      I haven't, but it's moot now because the project got re-worked with preset instead of pattr, and that solved it (no reason to go back again). Anyway, if it comes up in the future, I'll remember to try adding those folders. Thanks!
    • Dec 04 2014 | 11:46 am
      The same behaviour is also present in Max7. I was chasing the error for a while and finally pinned it down to the "searchformissingfiles" option of the standalone object. If you set it to 0 you will get the pattr_obex error.