Standalone: can't open resource... .jpg

    Apr 24 2006 | 6:36 pm
    I have run into a glitch. I have read the documenation and searched the list. This is a recent problem, by which i mean, i (feel like) i am not doing anything different but now there is a problem.
    I have made several standalones, and sometimes externals and files work fine including them into the collective in the build process, other times they seem not to be included, but this is fine, i simply open the package and drop them into the MacOS folder...and everything works out.
    However, i am rebuilding a standalone (which has worked fine in the past, this time i'm simply changing the MAx splash using the "appsplash" command in Build). When i rebuild this time and i open the App, it says "can't open resource cinema.jpg"-- a simple picture that is to be opened by The image is not problematic, it is the same image i have used before, and it works in the original Max patch. I have attempted to open the Package and manually include the jpg file. I reopen the app, and i get the same error. I have tried placing the jpg file in all the folders: resources, MacOS, support. Nothing seems to help open the file in the App.
    I have tried including the "jitlib" in the build and that doesn't make a difference. Regardless of whether jitlib is included or not, my App still plays quicktime movies, so i'm imagining that its not the object this is problematic.
    I also get a wierd error message: error: unable to find CG framework. I'm not using any object.
    Why would this not work all of a sudden? While writing this i have attempt to replicate my intial build which worked (not changing anything). I still get the same errors.
    I have attempted to build with two different OS systems:
    Powerbook 15": 1.5ghz G4
    maxmsp4.5.5/jitter1.5 on OSX 10.3.9 + maxmsp4.5.5/jitter1.5 on OSX 10.4.5
    Any help would be greatly appreciated.

    • Apr 24 2006 | 9:00 pm
      out of my head, wouldn't the spash have to be a ".pict" file ?
    • May 06 2006 | 4:29 am
      yes, i have made the splash image a .pict file. The splash is not the problem.
      The problem is that the standalone can't find a jpg needed to be loaded by a object.
      (I only mention the splash image because this was something changed in the build)
      thanks for the suggestion however.
      Anyone else have any ideas?
    • May 06 2006 | 5:49 am
      > The problem is that the standalone can't find a jpg needed to be > loaded by a object.
      Probably because you didn't define (in your patcher) the filepath requested by to load the jpg from the standalone. You could put the jpg inside the package as an attached resource.
      HTH, Philippe
    • May 06 2006 | 10:15 pm
      I don't know if you resolved it allready, but if not, I recently had some similar problem which was resolved with the following tips: the cg framework is located in the max folder > cycling 74 > jitter-externals. In order for the file to be found by the application, don't add it in when building the standalone and add it in the MacOs folder. If you ad the file when building the standalone, this will not work.