Standalone: unable to init mxj classloader. ERROR: -10

    Sep 27 2009 | 3:53 am
    I'm trying to create a standalone application that uses mxj with MaxMSP 4.6 under OS X 10.4. Here is a dmg that contains the source files as well as the problematic bundle:
    When I run the application, this is what I see in the status window:
    MXJ System CLASSPATH: /Volumes/tc1/Sources/amb/amb-v0.9/ MXJClassloader CLASSPATH: /Volumes/tc1/Sources/amb/amb-v0.9/ • error: (mxj add dir) unable to init mxj classloader. ERROR: -10 • error: Could not load class 'com/cycling74/max/MaxObject' • error: Could not find framework class com/cycling74/max/MaxObject • error: Could not find framework class com/cycling74/max/MaxObject ....
    mxj (and thus my app) seems to not work.
    I've copied max.jar into my bundle in "", and from the status messages, it seems to have been found.
    The only other hint of this error I can find is this -- but that seems unrelated, as I have no special characters in the path name. I had no problem an application bundle with these patchers with MaxMSP 4.5.
    Any idea what's going on?

    • Sep 27 2009 | 3:18 pm
      More info: The standalone actually seems to work fine from the .dmg. In fact, the only place it doesn't work is in my development directory, which is in a filevault home partition (thus the "/Volumes" path).
      If I copy the bundle outside of my filevaulted home directory, or run it from a separate dmg, it works fine.
    • Oct 31 2013 | 1:35 am
      I am hitting a similar error to above, and this looks like the most recent thread of
      '(mxj add dir) unable to init mxj classloader: ERROR -10' 'Could not load class 'com/cycling74/max/MaxObject''
      We have a customer attempting to use Liquid Rhythm through Max for Live patch in Ableton Live 9, and as soon as he upgrade to OSX 10.9 (Mavericks), the patch started to fail. We debugged the issue with him over skype, and narrowed it down the mxj startup. We have tried many times to reproduce the problem locally without any luck.
      We simplified it to the following steps:
      1) Create a new empty patch 2) Create an mxj 3) Right click the mxj and choose 'help'
      Then we see the attached Max console output.
      What is happening is MaxMSP is somehow corrupting the path to the max.jar. We thought it might be a Locale thing, but we check the System setting, and it is english. We verified in Finder, the path within is perfect. Yet somehow it is corrupted once it gets to JVM.
      Customers Specs Mac OSX 10.9 CPU: 2.2 GHz Intel Core i7 RAM: 8GB 1333 MHz DDR3
      Ableton Live 9.1b24 (but also same issue with Live 9.0) Max 6.1.4
    • Nov 14 2013 | 4:59 pm
      I was encountering this error too until a few minutes ago. I have Max 6.1.5 on two Macs, both running OS X 10.9. On one Mac, the error was occurring, but on the other, the patch was running fine. I saw that on the problem Mac, Max was munging the Java class paths as follows:
      MXJ System CLASSPATH: /Applications/Max 6.1/Cyclijav'74/java/lib/jitter.jar /Applications/Max 6.1/Cyclijav'74/java/lib/jode-1.1.2-pre-embedded.jar /Applications/Max 6.1/Cyclijav'74/java/lib/max.jar MXJClassloader CLASSPATH: /Applications/Max 6.1/Cyclijav'74/java/classes/
      (See that Cyclijav'74 directory - that doesn't exist!)
      I also realized that on my machine where it was running properly, I have the Max 6.1 folder inside another subfolder, "Audio", in my Applications folder. To see if that made any difference, I created a new subfolder, "Audio", in the Applications folder on the problem machine and dropped the Max 6.1 folder in there. I then re-started Max, ran the patch, and it worked!
      My guess is that re-launching Max from that new folder caused it to re-init the Java paths, which then corrected whatever path error was previously present. I then moved the Max folder out of the "Audio" sub-folder, re-launched the patch, and the error returned. Something must be getting cached - but in any case, dropping the Max app folder into a subfolder does appear to fix it for me. Curious if that works for anyone else.
    • Nov 30 2013 | 4:33 pm
      @PMT this is known (Mavericks specific issue) and fixed for the next incremental.
    • Dec 01 2013 | 5:38 pm
      Hey Emmanuel, cheers to the Cycling'74 team for the fast turn around :)