Strange error at building standalones persists in Max 6


    Dec 02 2011 | 8:20 pm
    The error message in the status window (window should not appear)is "pattr_obex: no such file in collective" when running a standalone built with Max 4, 5 or 6. My patch has a pattrsotare with @ gredy 1, in a "main patch" and then has four subpatchers (bpatchers) with autopattr and objects with names (names scripting) set by #1-slider etc in the "attributes" of each subpatcher. The standalone apparently works well, but I want to hide the status window. I find in the forum: https://cycling74.com/forums/standalone-building-spurious-error-messages http://groups.google.com/group/electrotap/browse_thread/thread/6abcb540845ed87f But zero solutions about that :(
    anyone know this error means? i try to include all pattr objects in the build to see. But no such luck.

    • Dec 02 2011 | 9:11 pm
      hiding the status window is possible using the [standalone] object. Open its inspector and select hide max window on startup.
    • Dec 02 2011 | 11:26 pm
      Thanks, but only if no errors, but, apparently, always open for display.
    • Feb 17 2012 | 11:43 am
      Hi, I have the same problem here. My standalone always says: "pattr_obex: no such file in collective" Did you ever fix that?
    • Mar 04 2012 | 2:34 am
      Bump!
      Same issue--- "pattr_obex: no such file in collective". What's going on? This is bad. I personally don't care if I get an error message, but this is a commercial product I'm building for a client...error messages (even if harmless) are kind of a dealbreaker, they look sloppy!
      Same issue with the Max Runtime window, it always appears no matter what the settings are in [standalone].
      To fix the multitude of "comment.svg: no such file in collective" etc., you need to "Include Folder..." and put in the folder "object-palettes" from the Max Application folder. Again, I think this should be included automatically, as it always appears to throw errors.
      XP, 5.1.8
      If these issues have been resolved in Max 6, great, but hopefully in 5 as well?
      Even just a fix for the pattr_obex issue??
      Help!!
    • Mar 04 2012 | 3:41 am
      Relatedly, I still have issues in Max 6 with it not copying Max.jar and Cg.framework (jitter-related) when I use [mxj] or [jit.gl.shader] respectively, directly or indirectly in a project. Any chance of a fix for these issues in an upcoming version?
    • Mar 04 2012 | 4:54 pm
      + 1 for automatic inclusion for mxj, Cg.framework and shader. btw. Max 6 also does not inlude jsextensions, if used. In Max 5 this was not the case.
    • Mar 04 2012 | 9:18 pm
      for the "maxwindow in runtime" problem: do you loadbang settings to your patcher windows? try a deferlow directly after the loadbang. that solved the for me once. the flag nomenu was always bringing up the maxwindow eventhough it was disabled in [standalone]. I don't know if that is still the case with latest max and that was windows only i think. O.