Strange problem with sfrecord and quickrecord - Can't record anything

    Jul 02 2011 | 12:34 pm
    I'm co-teaching a class in the basics in max/msp and arduino and one of our students has a very strange bug on his laptop when using sfrecord~ or quickrecord.
    When starting recordings it says: "can't open file for async access, err -1" "start requested without preceeding 'open'"
    And when pressing stop it finally says: "could not finish writing header for &, err -1
    In the output directory there is a file created but it's almost empty. It's as if there is header and space has been allocated for the length of the recording but the file is corrupt.
    He's running max on a pc laptop, latest version of max 5, windows xp, realtek soundcard with asio4all (also tried all the other sound drivers).
    We've tried many things, disabling the firewall, changing sound driver, anything basically. Nothing works. I've never come across this error message before. The patch is running, outputting audio and the patch is a general example that we've been using without previous problems. Any ideas?

    • May 05 2014 | 11:42 pm
      been running into this problem as well.
      I may give up on Max/MSP. I keep running into "Start requested without proceeding open" when I clearly have open commands DELAYED before running the record command. It's pretty insane. I think PureData is the way to go for time-critical tasks. sfrecord is extremely buggy. Lost 2 days of precious time trying to get it to work. The best part is that it still refuses to work!! wow! :)
    • May 06 2014 | 1:34 am
      ah, yep, my problem came down to the bangs going off at the wrong times...