Stupid Question: where to install external objects for Max5?

    Oct 14 2009 | 9:14 pm
    I did some searches here and couldn't find this (though I'd bet it's out on this forum somewhere). I downloaded some external objects to use with max6 on mac os x Leopard.
    Where do I put these objects so Max can use them?

    • Oct 14 2009 | 9:20 pm
      I've created a folder in the Cycling '74 folder called "Externals" and pointed towards it using Options > File Preferences. Once you restart max they should all be ready to go.
    • Oct 15 2009 | 1:11 pm
      bigtiny wrote on Wed, 14 October 2009 23:14 Where do I put these objects so Max can use them?
      Anywhere you want them.
      By default, Max searches the patches/ and examples/ folders in the main application folder, including a recursive walk through all subdirectories. If you want to put your externals somewhere else, add an item to File Preferences in the Max/MSP Options menu. Max will add this to its search path, as well recursively adding all subdirectories of the new path.
      Word to the wise: it is not a good idea to ask Max to add an entire entire hard disk to the search path, nor the path "/". And think twice before adding a path that includes a network folder.
      For more information, please look up "search path" in Max help.
    • May 31 2011 | 11:14 pm
      strange, has anyone installed the syphon external objects? i added a new directory but they don't seem to register even after i restart max..
    • Jun 01 2011 | 2:48 am
      I threw them into Max5/Cycling '74/syphon-public-beta/
      Restart Max, works fine. Macbook Pro 13" 10.6.8, max 5.1.8
    • Jul 06 2013 | 12:16 am
      Hey guys, I'm having trouble, too. So far I've tried to install [bonk~] and [fiddle~], with no luck. First, I tried putting them in Max/Cycling '74/msp-externals, then in a "3rd-Party" folder in the Cycling '74 folder. Neither worked. It's weird; they show up in the text completion menu when I create a new object, but when I hit return they become yellow and have no inlets or outputs. I restarted Max, restarted my computer, and reinstalled Max. No dice. Any ideas?
      MacBook Pro 17" 10.8.3, Max 6.1.3
    • Jul 06 2013 | 6:58 am
      Hi, try dobule clicking the objects. When the subpatch opens (I think that is how you have saved them) they should have inlet's and outlet's? Save THAT file, delete the other and then when you next create the object it should have the required in and out put's.
    • Jul 06 2013 | 12:55 pm
      I had the same problem.
      it turned out I was running Max in 64-bit. Try running the program in 32-bit and the externals may work.
    • Dec 30 2013 | 11:57 pm
      Hi everyone, I'm having similar problems installing bonk~
      It's in the Cycling '74/msp-externals folder and I can't see it in the text completion menu. I made a 3rd-party folder for the files and added the path in Options->File Preferences...
      Also I tried restarting, re-installing.
      Max 6.1.6 Running in 32-bit mode, Macbook Pro 17", 10.9.1.
      Please help!
    • Jan 04 2014 | 3:25 pm
      Hi, happy new year :)
      I just discovered that the name of the folder you make for your externals do matter, or at least don't call it anything with an "/".
      So, DO NOT call it "Max/MSP externals" ... Because then Max will search for a folder called MSP inside a folder called Max.
      Better DO THIS: "MaxMSP externals".
      Does this affect you Fastfourier?
    • Feb 24 2014 | 7:29 pm
      Okay so I've tried all the above stuff. I'm trying to install fiddle object. First I created a folder called extensions for it and set max/MSP to look there. This was after just putting it in mspexternals didn't work now its in both. Max/MSP is in 32-bit mode. The fiddle object just appears with no i/o's and the objects red.
      Did any of you guys manage to solve this issue? If so please help.
      Thanks in advance
      EDIT: Got latest os x and this is what i downloaded "fiddle~ version 1.2 for Mac Max/MSP OS X Mach-O Universal Binary with source."
    • Feb 25 2014 | 8:48 pm
      If you're having problems, the next thing to try is to manually "install" the external. You can do this by selecting Install... from the bottom of the File menu, then navigating to wherever you have the external and hitting Open. Alternately, you can just drag the external to the Max icon (or even just double-click on the .mxo icon, although that depends on having your OS set up correctly).
      Then make sure the Max window doesn't have any unsettling messages like:
      The external foobar couldn't be loaded. As always, should you or any of your force be caught, the Secretary will disavow any knowledge of your actions. Your computer will self-destruct in five seconds.
      If, otoh, if might get a message like "Foobaz loaded" (or nothing at all), now try to instantiate the object in a patch. Check the Max window again for messages. The Max window is your friend, it is trying to tell you stuff. Please let us know what it says.
      Only now that you're sure you've got a working object can you start to worry about whether you've put it somewhere in the Max search path.
      The note about folders with slash characters (/) in the folder name is worth noting. Can anyone confirm that this is still a problem with Max? (It's sort of a bug.)
    • Mar 05 2014 | 6:24 am
      I'm in 32-bit Windows 7. Created a folder called "externals" and within that a folder called "bonk". Extracted the bonk~ zip to that folder. Added the Max6.1/externals/ path => Go to Options on the Menu; then select File Preferences. Then choose to the externals path and make sure the Subfolders checkbox is checked. Restart Max. Bonk~ should now be available. Not sure where to put the helpfile as of yet. Trying to open the bonk~ help file via the right click menu crashes Max :(
    • Apr 05 2014 | 12:52 pm
      I had this problem too: external objects installed, in what should be the default search path giving autocomplete, but 'object not found'. I had initially placed the msp objects in their own sub-folders in the max-externals folder, then copied the sub-folders to msp-externals and deleted the objects (but not the sub-folders) from max-externals. When I deleted the empty sub-folders from max-externals, everything worked fine.
      All on WinXP/Max 6.1
      I think it's only a coincidence that it was for fiddle~ bonk~ and pitch~ for me too ;)
    • May 05 2014 | 10:42 am
      Spoke too soon. The problem came back. Double clicking on the help file worked at least once.
    • Jun 30 2014 | 7:35 pm
      I have tried a few suggestions on this feed, but I still am finding troubles getting my external to work... suggestions? I am trying to download the external loudness~ from I am a complete newbie to this and cannot seem to get this to work. I downloaded the zip file and extracted all files to C:\Program Files (x86)\Cycling '74\Max 6.1\Cycling '74\extensions. When I create a new object, loudness~ is on the dropdown menu, but when clicked it comes up red with no inputs or outputs and I receive "Error 5 loading external loudness~". When i double click I don't get a subpatcher. Can anyone help me get this working? Thanks
    • Apr 10 2016 | 9:23 pm
      I've tried all of the above and I'm still not able to use the objects that are listed when I type in the objects name.
      CNMAT library is the external. Macbook Pro 2015 Retina - El Capitan - Max 7.0.0
      UPDATE: 2016-04-10 23:36:15.565 Max[55456:7234193] Error loading /Users/123/Desktop/ dlopen(/Users/123/Desktop/ um.mxo/Contents/MacOS/list-accum, 262): no suitable image found. Did find: /Users/`123/Desktop/ no matching architecture in universal wrapper
    • Aug 01 2018 | 8:06 am
      >> "Error 5 loading external loudness~" I get error 5 when I don't have rights to execute the external. I do chmod 774 and it's gone.