Suppressing Max Window display on standalones

    Jan 21 2010 | 6:30 pm
    Does anyone know how you suppress the Max window from appearing automatically when you run a standalone generated from your patch?

    • Jan 21 2010 | 6:38 pm
      Ahh, found it. I didn't see the inspector option for [standalone] at first. I realise now it's called the status window :)
    • Jan 21 2010 | 6:42 pm
      You can use [standalone ]. It has an option to suppress the status window (Max window) at startup. You could then use [menubar ] to remove the option to open the max window from the munu in your application. I'm not sure exactly how or if it would be neccessary, but you could probably modify one of the json files (dunno which one) in the contents of your app to remove the keyboard shortcut that opens up the max window.
    • Jan 21 2010 | 6:42 pm
      too late haha
    • Jan 21 2010 | 7:06 pm
      There appears to be something wrong on Windows.
      I've built my patch for both Windows and OS X.
      I've used the [standalone] option to disable the status window on startup for both.
      On OS X, it's fine - it opens without the Max window.
      On Windows, it always opens with the Max window.
      Any ideas?
    • Jan 21 2010 | 8:11 pm
      OK, I've answered my own question.
      If you execute a 'window flag nomenu' then the Max Window will open even if it is disabled in the [standalone] object inspector.