Synth love error message

    Sep 20 2008 | 7:37 pm
    after about 8hrs straight of patching, i must have done something that my frazzled brain can not interpret at the moment. My favorite synth patch is giving me the following message in the message window:
    error parsing patcher file uc_license.maxpat parsing object, possible missing initial '{' character: line=1, char=4, text='...' newobj: uc_license: No such object
    i understand teh no such object aspect what i don't understand is the "parsing" parts. Any one have a second to shine a light for me? Thanks! -chuck

    • Sep 20 2008 | 9:39 pm
      Sounds like something I ran into, at least in part. There may be a control character in the maxpat file, and in earlier versions of 5, this often caused the patch to not open. Here's the thread I created for this problem; there's a relatively simple fix using TextWrangler on Mac -- "zap gremlins", which gets rid of nasty patch-breaking control characters. On Windows it was a little trickier to find an app that worked for this, but I eventually did.
      According to Cycling, the latest version of 5 has fixed this problem, so try updating first and see if that works.
      Not sure about the "no such object" message, but it may fix itself too.
      Unsettling for sure, but apparently with the new version it's no longer an issue.