teabox interface and clock source

    Jan 26 2012 | 2:34 pm
    I am working with a patch that incorporates a Teabox, connected via optical cable to my audio interface (M-audio Firewire 410). I am having an issue with syncing the audio interface and the teabox. As a result, my sensors work, but my audio sounds like garbage. I'm looking for info on how to sync all these devices (macbook pro, m-audio firewire 410, teabox) so they all communicate happily, and achieve good things.

    • Jan 26 2012 | 2:36 pm
      I should add that I tried using soundflower, with no luck. Also, I'm using the Teabox Bridge application for the sake of sending MIDI data from the sensor.
    • Jan 28 2012 | 10:09 pm
      I don't know much about the M-Audio carb but I am using a similar setup with a MOTU Traveler successfully. However are you sure the soundcard is set to run at 44.1k ?
    • Jan 30 2012 | 3:39 pm
      What kind of garbage does the audio sound like? Is it pitch shifted from the original, scratchy, etc. As I recall, the 410 has a setup app that you use to set the clock to external sync. Out of curiosity, is that still the case? Also, what version of OS X are you running?
    • Feb 07 2012 | 3:10 pm
      I've set the M-audio app to sync externally. I'm no longer sure that this is the issue. I've bypassed the interface (sending audio in and out of the computer itself) and have the same results with the computer alone. So I think this is a Max/MSP issue. I've also tried the same patch and setup on two different computers (both macbook pros, two different generations) with the same results.
      The sound I'm getting changes with every click of the "on" button to the DAC. I'm running three different real-time processes in my patch. Each time I turn on the ADC/DAC I get a different version of digital audio stutter - it's almost as if I'm jumping into the audio just slightly out of sync with the sample rate, so I get a jittery, stuttering, version of the analog signal coming in.
      I think I may be missing something in the patch itself. But all of the processes pull from the same adc, and get sent to the same dac. one click turns on both. I've adjusted the I/O vector size and the Signal vector size to match, at the largest value, to try to cut down on CPU load. That fixed it temporarily but now it's back. (and for what it's worth, the CPU load has never been over 5 or 10%. Never in overload. And no other apps, save for the M-audio and Teabox bridge app, are running)
    • Mar 12 2012 | 10:47 am
      Hey bd75, have you solved your problem ? I have a similar issue with a TeaBox connected to the optical input of a MacBook Pro. The input signal is clean when adc~ is activated at first but becomes dirty after some time (many spikes). However I would like to find if it's a TeaBox or a MacBook Pro issue.
    • Mar 13 2012 | 10:59 pm
      I'm using profire 610/MacBook Pro with Teabox. I do not have problems at all, by using: soundcard on external sync; S/PDIF connection, assigning an individual adc~ object to profire channel 5 S/PDIF entry (adc~ 5)/ use of teabox~ object. Use of mute~/pass~ to activate only if required.
    • Mar 16 2012 | 10:11 am
      Thanks for the info Helmuth.