textures fill the memory and crash

    Oct 17 2013 | 9:53 pm
    Hi, I have a big problem for several months:
    In a bpatcher i load and reload different patches whit inside a lot of jit.gl.slab and jit.gl.pix after some hours my patch crash and i discovered by "Opengl driver monitor" that the texture number increase after each replacement in the subpatch until the crash here there is a patch you can reproduce the bug and here two images to better understand the problem.
    Can someone help me I'm on the new 6.1.4

    • Oct 17 2013 | 9:56 pm
      here the screenshots see the textures red number in "OpenGL driver monitor"
    • Oct 21 2013 | 10:14 pm
      can someone reproduce this bug?
    • Oct 22 2013 | 7:41 pm
      hi micron. where is the patch?
    • Oct 22 2013 | 7:58 pm
      ops yes... here is the patch
    • Oct 23 2013 | 11:42 pm
      Hi Micron,
      Many thanks for following up on this. We believe we've solved the most serious of memory leaks here (thanks again for your great reporting on that which helped us find numerous issues).
      However, I am able to reproduce your reported behavior in OpenGL Driver Monitor, despite the fact that we have matched pairs of glGenTextures and glDeleteTextures, and we consistently reuse the same texture ids. The OpenGL driver monitor reports them growing however, which is curious, and suggests that it marks them for "garbage collection" or similar at a later point.
      On a lark, I tried deleting the context and rebuilding it, and it would seem seem from using OpenGL monitor that in such a case, it reclaims these textures. I'm not sure of a better way to trigger this reclamation at this point and I didn't let run long enough to confirm whether or not it solves the crashes, but please try sending the jit.window object the message "depthbuffer 0, depthbuffer 1" to reclaim these textures, and let us know what you find.
      Thanks, Joshua
    • Oct 31 2013 | 6:44 pm
      hi micron. thanks again for the report. we've managed to isolate this memory leak, and have fixed for the next update.
    • Oct 31 2013 | 8:15 pm
      Thanks Joshua, your workaround works for my patch. Thanks Rob for your support.