The PRINT object is printing super fast in the Max window

    Mar 31 2012 | 12:18 pm
    I have a subpatch in which the User presses a Start Button, then the user chooses the speed of answering, slow, medium or fast, and in the Max Window there are two choices printed of which one of them is the right one. The user then chooses the choice of two answers in the subpatch which he/she thinks is the right choice.
    The PROBLEM IS THIS, when the user presses on the Start button, all of the questions are printed in a super fast in the Max window and the user does not have a chance to choose an answer. The problem sometimes resolves once the user presses the Start button and selects the speed of answering, but it is not always reliable.
    Can you help Please resolve this issue ? Attached is the subpatch so you get a better picture
    Thank You, Kate

    • Mar 31 2012 | 1:12 pm
      Looks fine except that you are missing an argument in metro to set the default value. Without an argument metro I think defaults to 5 milliseconds. You'd probably want it set to something like the easiest setting by default to give people time to turn down the speed.
    • Mar 31 2012 | 5:35 pm
      Thank You a lot for the suggestion. I didn't even thought of that. The thing with MAX is that the solution is always something easy that you would not think off.
      Thank You again, Kate