to_texture problem


    Apr 21 2006 | 10:48 pm
    I've worked with the to_texture method in my patch for some time and it
    always worked well without taxing my cpu too much. I started cleaning up
    some things all over the place and now to_texture has become a big problem.
    I've been debugging for many hours now and it's really driving me insane.
    A texture of 640x480 is already increasing my cpu from 25 to 100 and
    dropping my framerate to 6fps. If I just use to_texture, without actually
    drawing the texture on an object, nothing happens. Also processing it with
    slabs doesn't really change my cpu. Its when I send "texture_xxx" to a grid
    or videoplane and bang it when my computer goes nuts.
    Is there anyone that has experience with a situation like this or can think
    of a possible reason why this could happen? I feel like an ass because it
    has always worked. I know this sounds vague, and I'd post the patch if I
    could but I can't. Just hoping someone has run into this problem before...
    Thijs

    • Apr 23 2006 | 11:21 am
      I finally found the little bugger after 2 days of hair pulling. By accident
      I passed the jit.window dimensions to the jit.gl.videoplane. This screws up
      your cpu real bad.
      The standard dimension for the videoplane is 20x20, but since I just use it
      as a flat plane setting @dim 1 1 gave me a small performance boost. About 2%
      on my computer for just one plane, so I you use multiple it might be worth
      changing this setting.
      I've always wondered, is there an important difference between [
      jit.gl.videoplane @interp 0] and texturing a [jit.gl.gridshape @shape
      plane]?
      Thijs