Forums > Max For Live

ableton8.2.2 m4live 5.1.8 certain pluggo intruments dont work

April 4, 2011 | 8:09 am

after the update ableton8.2.2 m4 live 5.1.8 alle the pluggo bassinstruments and additive heaven dont work anymore. all other instruments / effects run perfectly (vst / m4 live instruments like granulator / analogue drums / etc)
i have midi in signal but no audio out
system macosx10.6.6
ableton 8.2.2
max 4 live5.1.8
8 gb Ram
i7 2.8 GHz CPU
amt8 midi interface
rme fireface
anybody experiencing the same problem?

April 4, 2011 | 7:01 pm

same problem for me. when i open the patch, the max window says: " imiscctrl: no such object " and two other objects are missing. maybe one can replace these objects, but i dont know what they did and at the moment dont have the time to find that out.
if you can fix that, let me know, cause these are useful devices for me too.
good luck!

April 4, 2011 | 7:37 pm

It sounds like you may have some old stuff floating around from a previous MFL Live Pack, or the Max 5.1.8 install didn’t go as it should.

When you go to /Applications/Max5/patches/m4l-patches/Pluggo for Live resources/patches/ do you see lMiscCtrl.maxpat?

If not, lets do a clean install. To clean out Max 5 entirely, remove these items:

~/Library/Preferences/Max5 Preferences Folder

Then download and reinstall 5.1.8:


April 4, 2011 | 7:40 pm

tremellow and tapped delay also dont work. i guess they are just not updated. i will try to uninstall and reinstall to get the new versions. for me this is fortunatly just afew hours on finding the problem and reinstalling. but imagine this before a gig. this is really bad work from ableton and cyling74 ! can`t they just test an update before release?

April 4, 2011 | 9:11 pm

ok. i had to go in live to settings/library/ repair library. now i got the new max4live content. although a little hint would have been nice and had me saved hours.
i dont have the imiscctrl either. doing reinstall at the moment. actually this is a little annoying for just updating a programme

April 5, 2011 | 1:25 am

jazzpa… check your externals in the Cycling74 folder…

After a full uninstall and install I stepped through and found some externals were messing with the max/live communication. But even then, you will need to do a full install and then test each external.

So I would install… open live… run something that was broken…



its a massive pain, but my stuff is now working after months of issues.

April 5, 2011 | 7:46 am

hello everybody

after i did a library repair in the preferences panel of live all my m4l instruments/efx are running ok
as a matter of fact the max library had to be updated

have a nice day


February 25, 2013 | 8:44 pm

I am having this problem now, trying to get the Pluggo Instrument "Bassline" to work with Ableton 8.3.4 and Max 5.1.9.

The instrument loads in Ableton, but does not produce sound. Opening it in Max with the edit button reveals why

newobj: lMiscCtrlFixed: No such object
newobj: lMiscCtrl: No such object     < -- this line appears 20x
newobj: lVoiceCmd_exclude: No such object

I have re-installed Ableton, and Max. I have asked Ableton to repair its library twice. All for naught.

So I followed Ben's suggestion above, to check in /Applications/Max5/patches/m4l-patches/Pluggo for Live resources/patches/ for lMiscCtrl.maxpat. And no, it's not there.

However, I then grabbed the Max 5.1.9 installer and looked inside it. The lMiscCtrl file is missing from the installer as well! So it seems that the burden is on Cycling '74 to include this file in the installer.

Please advise.

February 25, 2013 | 8:52 pm

Actually, I just found these files in an old archived installer I had, so I got it working.

The issue is that the Pluggo instrument is looking for a file called lMiscCtrl.maxpat, but in the current Max installer, this file has been renamed (and its content slightly updated) to pluggo.MiscCtrl.maxpat.

So, either you can dig up the old version of the missing patch file, or you can update the Pluggo instrument to use the new version.

February 25, 2013 | 9:04 pm

Arg, but other stuff is still not working… for example, the Laverne Pluggo instrument. When I open it for editing, Max’s status window complains that patcher laverne_voice is missing, and no I can’t find that anywhere in my own archives to manually patch.

Like I said, I’ve already reinstalled the current versions of both Max and Ableton, and had Ableton repair the library. Not sure what I’m doing wrong here.

February 26, 2013 | 9:09 pm

I had more time to look into this today – got Laverne working and again, this is was a naming issue. Somehow I have a weird mix of new and old .amxd Max Instrument files and .pat support files.

In this case, the Laverne instrument wanted a support patcher called laverne_voice.maxpat but the one I had was named lav.Voice~.maxpat. So I fixed it by editing the Laverne instrument (in this case, changing a poly~ object) to look for the file I had.

Can any Cycling ’74 staff please tell me, which is the new naming convention, and which is the old? Or even better, give me a clue as to what is going on here? In Ableton’s preferences, I asked it to remove the "Max for Live Content" pack, and then I reinstalled it, so I don’t know why it’s still having this issue. (Ableton says my "Max for Live Content" is currently at version 2.2.)



Viewing 11 posts - 1 through 11 (of 11 total)

Forums > Max For Live