Forums > MaxMSP

Are these features removed from Max 6 ?

October 28, 2011 | 12:07 pm

There’s no more keyboard shortcut for the "Route patch cords" message in the Mac version althought it seems to be one in the Windows version.

Option + click on the title of a subwindow could open the original file (nice for pfft~, poly~, abstractions) in Max for ages. It does not work in Max 6.

October 28, 2011 | 1:13 pm

not at max at the moment, but i think i had the same issue and the shortcut just changed..found it after a while, i think it involved the "a" key, instead of "y".. not sure about all of that, maybe dreaming.

October 28, 2011 | 3:56 pm

Not at Max, either, but can’t you still modify all keyboard shortcuts by editing the appropriate .json file?

October 28, 2011 | 5:45 pm

"Route Patch Cords" is still [shift+command+Y].

The new way to open original patchers is the button second from the left on the lower toolbar of the patcher. It’s called "Patcher Windows" and brings up options when you click it.

October 28, 2011 | 7:27 pm

"Route Patch Cords" is still [shift+command+Y].

Really? Perhaps there is a bug, because most of the time command+shift+Y doesn’t do anything for me in Max6, but if I choose "Route Patch Cords" from the contextual menu it works. (But I think for some reason command+shift+Y might have worked for me one time so far in Max6).

Tested on MacBook Pro 2.2GHz Core2Duo (T7500) 4MB RAM running OS X 10.6.7

October 28, 2011 | 7:54 pm

Hi Roth,

command+shift+y appears to work here. Make sure you have the release version of Max 6, r50568 on Mac.


October 28, 2011 | 7:56 pm

Yeah, yesterday I probably worked for about an hour after I had purchased the upgrade and authorized before I realized I was still using the beta build!

October 28, 2011 | 10:31 pm

I have checked my version of Max. It’s the 6.0.0 (50568) and however command+shift+Y doesn’t produce anything (MBP i7 quad / MacOS X 10.6.7).

stringtapper wrote:
"The new way to open original patchers is the button second from the left on the lower toolbar of the patcher. It’s called "Patcher Windows" and brings up options when you click it."

Adding a new way to do it is fine but I’d have appreciated the old way would have been keeped whatsoever. I see no point at all in suppressing it.

October 28, 2011 | 11:11 pm

@Roald regarding the patcher option click in the toolbar, we tried hard to implement this feature, but the switch to Cocoa made this incredibly difficult for us to implement with our codebase. It was not suppressed simply because we were being whimsical about it.

October 28, 2011 | 11:18 pm

It makes more sense to have an actual button with a label anyway. The old way had a bit of a "secret handshake" vibe to it. An age-old secret passed down through oral tradition by the electro-acoustic professors of yore.

Or at least that’s how I learned about it…

October 28, 2011 | 11:20 pm

Yes, we also felt like it was an undiscoverable feature in the old way, but we probably would have kept that as a means of accomplishing similar if it were not such a PITA to implement for us under cocoa.

October 28, 2011 | 11:26 pm


When you go to the ‘Arrange’ menu, do you see the key command for ‘Route Patchcords’? If not, something is wrong with your install and you should blow away preferences and reinstall.

Preferences are now stored here:

~/Library/Application Support/Cycling ’74


October 29, 2011 | 8:29 am

Trashing the preferences solved the "Route patch cords" problem. Thanks Ben.

Thanks to the C74 team for having tried to keep the older way to access original patchers. I suppose evolution has its unavoidable drawbacks.

October 30, 2011 | 11:49 am

Double checked and I am experience this problem on 6.0.0 r50568. It appears as though what was happening to me was that command-shift-y would work once and then would stop working until I restarted Max (different from my experience with beta r50048 where it would not work at all). Choosing "Route Patch Cords" from the contextual menus is working fine.

I tried trashing my preferences and reinstalling Max6 and now command-shift-y won’t even work once for me.

October 30, 2011 | 2:02 pm

Use OSX’s system preference -> Keyboard -> Keyboard Shortcuts -> Application Shortcuts to add a short cut for "Route Patch Cords" in Max should work.

March 28, 2012 | 6:59 pm

I’ve just upgraded from Max 5 to 6.0.4 52278 and I’m getting the same problem with route patch cords.

I setup a keyboard shortcut and this doesn’t work.
I removed Maxpreferences.maxpref from my Library/Application Support/Cycling ’74 directory. Restarted Max, still not working.

I like to keep my patches tidy, and rely on this feature quite a lot so any fix a beauty.

March 28, 2012 | 7:25 pm

Hmm, found a weird bug. I too don’t have the shortcut option to route patchcords. It does appear in my arrange menu, but it doesn’t list the key combo for it next to it. If I trash my prefs then the key combo appears next to it in the arrange menu again, but as soon as I use shift+command+Y OR just plain old command+Y then the key combo disappears again and the shortcut stops working. Guess I’ll go reinstall…

March 28, 2012 | 7:44 pm

I’ve just noticed this is also happening for shift-command E to encapsulate.

March 28, 2012 | 9:08 pm

We have gotten a few reports on this behavior, but have yet to track it down. There seems to be very little rhyme or reason why it happens on some machines and not on others, though the common thread seems to be 10.6.8.

I’ll continue to try and track this down.


March 28, 2012 | 9:37 pm

Yeah, 10.6.8 here

March 28, 2012 | 9:42 pm

I’m on 10.6.8 too.

March 29, 2012 | 2:51 pm

10.6.8 here too, "shift+command+s" for "save as" disappeared..

March 30, 2012 | 12:09 pm

Same here! 10.6.8 and build 52278.

January 31, 2013 | 11:28 pm

still on 10.6.8 and "save as" has no key command. Is this problem OS specific?


February 3, 2013 | 7:30 am

Route patch cords shortcut didn’t work anymore for me when I upgraded to 10.6.8 but is back now ni 10.8.2…

Viewing 25 posts - 1 through 25 (of 25 total)

Forums > MaxMSP