Forums > MaxMSP

Assigning a graphics tablet

Dec 06 2010 | 10:04 am

I want to be able to use my AIPTEK graphics tablet to control parameters in Max. I have tried downloading the wacom object from but it comes as an sit file. After numerous attempts of copying and pasting the text I seem to be getting no where.

Currently the tablet controls like a mouse but I only want it control drawing on two graphs.

As anyone got any ideas?



Dec 06 2010 | 3:37 pm

Have you tried the [hi] object?

Dec 06 2010 | 4:09 pm

Wacom objet’s latest version (4.0) is available from the CNMAT and is not provided as a .sit file.

Dec 06 2010 | 4:22 pm

I never achieved to get [wacom] working well.
I am using OSCulator and really have no troubles with my tablet, wii and others.

Dec 06 2010 | 4:33 pm

Cheers for the responses, I ve tried the [hi] object and the [wacom] object, with the wacom I am unable to get any values, with the hi object I am able to receive values out when using my mouse but not when using the tablet, also looking for a way to toggle what the tablet controls between two graphs, was looking at the gswitch 2 as a toggle. Any suggestions are much appreciated.

Thanks, below is a part of the patch:

-- Pasted Max Patch, click to expand. --

Dec 06 2010 | 7:52 pm

unless the [hi] recognizes the tablet directly, you’d need a working [wacom] object to do the driving. for switching between two graphs, this is a different question, unless you want to use the tablet (maybe if it has buttons) to switch, very straightforward with [gate 2]. you don’t want [switch] in this case, you want one stream of values (your X and Y) to go to one of two graphs, not the other way around: [switch] would take two different streams of values (like from two graphs) and funnel it into one output stream.

Dec 07 2010 | 3:13 pm

When we have tried to use the [hi] object with our tablet, it is recognized when we click on the [umenu] but it does not give any values. It still acts as a mouse would though.

We have encountered further problems when trying to use the [wacom] object. It displays no wacom drivers installed in the max window. We have installed the driver for the AIPTEK HyperPen Mini.

Now when we try to use the [wacom] object, as soon as we touch the tablet, it closes Max?

Any help would be greatly appreciated.


Dec 07 2010 | 3:39 pm

I have a AIPTEK tablet – AFAIK it’s basically the same as WALTOP (BTW, in germany this tablet is sold under the name of MEDION ;). I had a hard time finding an appropriate mac driver…ended up at a japanese site…

It naturally doesn’t work with the [wacom] object, because wacom uses its own protocol. It gets recognized by the [hi] object, but it doesn’t output any data.

So I’ve written my own external, which reads the HID data through apple’s API. It works quite good. I haven’t made the external public, because I’ve only tested it with my tablet on my computer so far.

It’s basically the apple’s HID example code pasted into MAX’s SDK…

If you want to give it a try, I would be happy to share.
I would need your tablet’s Device and Vendor ID, because I hardcoded them into the external to find the device. You can see the IDs in the System Profiler.

…the external is for intel-mac…

Dec 08 2010 | 3:24 pm

Hi that would be greatly appreciated, all the information available to me in the system profiler is:


Product ID: 0x0037
Vendor ID: 0x172f
Version: 1.01
Speed: Up to 12 Mb/sec
Manufacturer: WALTOP
Location ID: 0x1d100000
Current Available (mA): 500
Current Required (mA): 100


Dec 08 2010 | 6:30 pm

Here you go:

You need to provide the product ID & vendor ID as arguments to the tablet object. For your tablet this would be:
[tablet 0x37 0x172f]

Currently, only polling is supported.
You get values for x, y, pressure and buttons.

Good luck ;)

Please let me know, if this works…

Dec 09 2010 | 12:51 pm

Thank you very much. I’ll give it a try now and let you know how it goes.

Dec 09 2010 | 2:38 pm

I have just tried the patch and it gives out values when using the tablet. If I connect the x/y pad to the top graph/multislider through a scaling object, it enables me to draw a sequence through the x/y pad. I’m not quite sure though as to where I would connect them to on the below buffer, enabling me to draw in a shape.

The tablet also still controls like a mouse would do. Is it possible for it to only draw inside the x/y object?

Thanks for all your help.


Dec 09 2010 | 3:06 pm

*freu* *freu* (^_^)

the x/y pad (pictslider) is just for visual feedback. You can directly use [tablet]’s outlets for x, y, pressure and buttons.

By accident, I’ve found out, that when you kill the tablet driver app (in Terminal type "killall HyperPenDriver", the tablet will stop to control the mouse but continue to work with the [tablet] object !

I’m using a driver, which installer is called "Pen Pad Driver". I don’t remember, where i got it…

If you want to draw into a [buffer~] without using the tablet as a mouse, you can use [peek~].

Dec 09 2010 | 4:36 pm

Again thanks for your help. I’ve tried typing "killallHyperPenDriver" as well as "PenPadDriver" but it replies with an unknown command?

Dec 09 2010 | 10:19 pm

There needs to be a space between "killall" and "HyperPenDriver".
killall is a command which kills (quits) all processes with a given name.
HyperPenDriver is the name of the application, that is running in the background.

Oct 03 2011 | 10:11 am


I realise this is a very old thread. Still i was hoping to get a copy of that code using the following info:

Product ID: 0x0034
Vendor ID: 0x172f
Version: 11.05
Speed: Up to 12 Mb/sec
Manufacturer: WALTOP International Corp.
Location ID: 0xfa130000 / 6
Current Available (mA): 500
Current Required (mA): 100

As you can see it’s almost exactly the same as djstumerch ‘s tablet. sadly the code doesn’t work for me. I hope this is still possible, and doesn’t require too much work. Thanks in advance.

Oct 09 2011 | 9:51 am

Hello Mr. Penguin,

i need some more info to help you..

if you create [tablet 0x34 0x172f] and send it a bang, are there any messages posted in max’s window ?

Which version of OS X are you running?
I’ve just had a look at the code and i realized, that it uses an obsolete interface of the IOKit. It might well be, that apple decided to take them down on Lion…it works for me on Snow Leopoard, though..

Are you able to use the tablet in another application ?

Viewing 17 posts - 1 through 17 (of 17 total)

Forums > MaxMSP