Forums > MaxMSP

AU DLS Synth 1

Mar 25 2006 | 3:44 pm

Hi There,

I’m a very recent beginner (I’m currently on Tutorial
20 of the manual)
and I’ve suddenly come across a problem with Max
outputting midi data to
the Quicktime synth. This has only recently happened
as I’ve been
working through the tutorials using the Quciktime
synth fine. Now Max
can send midi to other virtual synths (such as
Simplesynth) (and there
is no problem get midi data in) but I no longer here
midi notes sent to
the Quicktime synth.

I’ve checked the list archives, and read an old thread
referring to the
AUgraph object but to no avail. The strange thing is
I’ve checked the
synth using other applications (such as Live or midi
files) and it
appears to still work fine?

I’m running 4.5.7 after thinking upgrading would solve

Any ideas?

Thanks in advance.


Chris Weaver
Station Manager
Studio Number 44 (0)207 836 3664

Win a BlackBerry device from O2 with Yahoo!. Enter now.

Mar 25 2006 | 7:26 pm

Hi Chris,

No prob here, Max/MSP 4.5.7 – QT 7.0.4 – OSX 4.5

Just test your setup with the MIDItester patcher from the Extras
menu, it should work fine.


Mar 26 2006 | 2:03 am

I can confirm this problem. "AU DLS Synth 1" has not worked with
noteout for a few weeks on my machine. I was playing around with
soundfonts using the fluidsynth~ object around that same time.

I was using 4.5.5, so I downloaded and installed the updated augraph
object… still broken. I just updated to 4.5.7 and still no luck with
noteout. Any more information on how to correctly reset the driver
bank is appreciated.

#SM driver loadbank 0 "AU DLS Synth 1"

This doesn’t work and a cursory look in the documentation didn’t turn
up any more info.


Mar 26 2006 | 3:22 am


Works really fine for me, through noteout or through midiformat-
Have you tried to load some soundfonts with max messages, something
like that:

– load a soundfont called Synth1.sf2 (change for any other sf,
double-quote if the filename contains space chars), located in your
root library:

#SM driver loadbank Synth1.sf2 "AU DLS Synth 1"

– set back the default QuickTime DLS:

#SM driver loadbank 0 "AU DLS Synth 1"

Otherwise, quit Max, delete some preferences files, or the the whole
"Max 4 Preferences Folder".


Mar 26 2006 | 8:22 am

I recently had some kind of problems too… I tried to send messages to
;max, but it didn’t help. I also though that the volume level of the
DLS Synth was set to 0 (you can change it with the MIDI volume
My only solution was to throw away some preference file
(midi@augraph.txt maybe) and restart Max.


Mar 26 2006 | 5:52 pm

Ok, it is working now. In my case it turned out to be a simple matter
of having the i/o vector size set too high. Dropping it from 2048 to
1024 or lower solved the problem.

Thanks to all for your responses,

Mar 27 2006 | 7:32 pm

Got the it working again! Deleted the preferences in
Support/Cycling74/Mididrivers restarted no effect.
Changed i/o vector
size as suggested above (thanks Danny) works fine –
great back to the
tutorials :-)


Chris Weaver
Station Manager
Studio Number 44 (0)207 836 3664
Mobile 44 (0)770 856 4715

Mar 27 2006 | 9:59 pm

Has anyone ever on a Mac successfully created a new DLS outport and
loaded a new soundfont ? I’d like to hear from you.
I keep getting the following error: � error: augraph: bank set error


Mar 27 2006 | 11:50 pm

Great Chris, glad it worked.

In the interest of being complete I will note that Patrick was
referring to the preferences in "~/Library/Preferences/Max 4
Preferences Folder/ ". Specifically, deleting my "CoreAudio@Built-in
Aud.txt" file reset the i/o vector size to an acceptable default level.
I am not sure that deleting /Library/Application
Support/Cycling74/Mididrivers is a good idea.


Mar 28 2006 | 8:51 am

Thanks Danny to take care of my posts! Indeed, I was of course referring to the users’s preference folder. But I’m quite sure now that
it was the midi@augraph.txt preference file that I deleted.

Patrick Delges

Centre de Recherches et de Formation Musicales de Wallonie asbl

Mar 28 2006 | 10:41 am

I did, successfully!
And still works fine: OSX 4.5 – Max/MSP 4.5.7

Would you post a patcher to check if it works here?


Mar 28 2006 | 6:58 pm

Sure. Here we go…

Thank you!


P.S. Download the DLS Toy Piano from

Mar 28 2006 | 9:07 pm

yeah, deleting the Mididrivers folder isn’t a good
idea as it deletes
the gui that configures the midi preferences! I
deleted it started the
program then put it back when I realised what I had
done. The vector
size was the winner.


Chris Weaver
Station Manager
Studio Number 44 (0)207 836 3664
Mobile 44 (0)770 856 4715

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > MaxMSP