Forums > MaxMSP

auto-completion problem for standard max/msp objects

Nov 10 2009 | 11:58 am


I have had this problem for a while, thought it wouldn’t bother me but it has starting niggling away and slowing down my workflow Smile I am confused as to why I can’t see some standard max and msp object names appearing in the drop down menu when I start typing in the object box?? Things like cycle~, line~, metro and a host of other standard objects don’t drop down – I need to type them in fully. There is no problem with max finding these objects once they are typed correctly – however I did like having to only type one or two letters to get to the drop down menu.

Any ideas? I have set the file preferences correctly – with the application folder in there as well as other folders in which I have externals stored.

Thanks in advance,


Nov 10 2009 | 2:10 pm

Do try to harvest metadata again. Paste this into a max window and click it. I had some trouble with the autocomplete menu when I ran a second instance of Max before. The documents that contain these are in Cycling ’74/init in your Max folder.

— Pasted Max Patch, click to expand. —
Nov 10 2009 | 9:21 pm

Perfect, that fixed the problem immediately – thanks for this!!

Feb 05 2011 | 9:57 am

yeah !!!!!

Mar 26 2011 | 10:32 am

Thanks for this Bas, I was running into exactly this problem and your solution worked.

Apr 22 2011 | 7:05 pm


I still have the same problems after using this db.reset method. I cannot see any autocompletion, although it had worked before. The "Object box autocompletion" is activated. What else do I have to consider?

Thank you!

May 22 2011 | 10:44 pm

Hi, I remember coming across this post a month ago, and I am now having the same problem.

The only change I’ve made to Max is setting the default grid size to a smaller grid for unlocked patches. Next thing I know, Max doesn’t auto-complete for new objects!

I hadn’t upgraded to 5.1.8 yet, so I was hoping that would help, but no luck.

I’ve tried the reset that Bas van der Graaff posted, but this still doesn’t solve the problem.

Do I need to delete a preference file maybe?


Jan 15 2012 | 9:33 pm

omg Bas thank you!!!!

Jan 15 2012 | 10:07 pm


At first Bas’ reset didn’t work for me, but after restarting Max, i disabled and enabled autocompletion and now everything works again.

So anyhow, thanks Bas!

Jun 23 2012 | 6:01 pm

Great tip, thanks!

Sep 26 2012 | 7:15 am

Auto-completion fail strikes back. Neither the ; max db.reset nor the disable/enable tricks worked…

Sep 26 2012 | 12:00 pm

Fours hours later, after restarting quitting, etc and opening and working with max 5 (?) this finally works. But the behaviour seems a bit erratic. Let’s see if other users get the same problem. Does the database rest message need time to operate ?

Jun 13 2015 | 6:22 am

I have a somewhat similar problem. Everytime I try to make a new object with Command-N, it pops up already auto-filled with a bpatcher. Tried all the listed solutions above. ANy ideas?

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > MaxMSP