Forums > MaxMSP

buffer~ write permissions error


June 15, 2013 | 3:04 pm

Hi All,

I’m getting an error when writing buffer~ files using the "write" message. If I supply just a filename, I get a permissions error: "jsoundfile_writefloats: could not create output stream. check permissions of output directory." If I supply an absolute path, the file writes no problem.

write myBuff.aiff –> error
write "Macintosh HD:/Users/david/Desktop/bufferwritetest/myBuff.aiff" –> writes file

Thanks!
David

April 19, 2015 | 9:54 am

Same problem here , I can write to disk from buffer if I manually provide a location "C:/here.wav"

But if I try to write to disk with a message box (write here) or many other variations , it fails with the same error message above plus could not create file.

could there be a work around? Perhaps max can display where the standalone or main prog is located as a message. If so, by prepending that with "write" and appending it with here.wav it should be possible to save a file without the need for user input with a opendialog….and be able to find that file again without user input.

thanks

p.s max states "A standard file dialog is opened for naming the file unless the word write is followed by a symbol, in which case the file is saved in the current default folder, using the symbol as the filename" = this does not seem to work.

April 19, 2015 | 10:56 am

a solution that worked for me on windows xp 64

within a patch use an object called (standalone) in its inspector check make application subfolder search path.

use " write ./this.wav"

the wav is then stored in the patcher location.

and " read ./this.wav " to refill buffer.

: )

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP