Forums > MaxMSP

[bug] Guaranteed crash?

Nov 05 2010 | 9:17 pm

I just noticed that if I create a new patcher and inspect several different objects in the inspector and then by mistake close the patcher, Max crashes. This is only the case if the patch hasn’t been saved previously.

Steps to reproduce:

put some different objects into a new patcher (toggle, bang, message)
select all and open inspector
switch back to patcher without deselecting the objects (i.e. the inspector still shows all attributes)
close the patcher without saving

=> crash

It’s not a big issue, and I only noticed it because I am clumsy and happen to press command+w a lot instead of command+e…

Can anyone reproduce this?

MBP 10.6.4
Max 5.1.5

Nov 05 2010 | 10:05 pm

I haven’t been able to reproduce. Also on 5.1.5, 10.6.4

Have you tried trashing prefs?

Preferences are stored here:

~/Library/Preferences/Max5 Preferences Folder

Nov 05 2010 | 11:24 pm

I can reproduce here on latest OS X and latest MaxMSP version.

@Dave – first time I tried I didn’t get it to happen but I’d missed the key line:

*switch back to patcher without deselecting the objects (i.e. the inspector still shows all attributes)*

Actually for me it is irrelevant whether or no the patch has been saved. The problem is that multiple items in the inspector do not get cleared when the patch is closed, and then it crashes.


Nov 05 2010 | 11:42 pm

Confirmed on OSX 10.6.4 with Max 5.1.4

Nov 06 2010 | 12:19 am

@Alex – you are right, crashes if it saved or not.

@Tim – thanks for the confirmation.

Nov 06 2010 | 12:51 am

can not reproduce using 5.1.5 on 10.4.11

Nov 06 2010 | 6:16 pm

Thanks for the report. I can repro and we will take a closer look.


Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP