Forums > MaxMSP

Bug? Max 6.1.2 64 bit as ReWire client in Logic 64 bit

Apr 20 2013 | 5:07 am

Yes it’s ReWire blues. Your help is appreciated!
OSx 10.8.3
Max 6.1.2 in 64 bit mode
Logic 9.1.8 in 64 bit mode
My goal is to get [transport] sync’d to Logic*
When I use Max 6.0.8 and Logic 9.1.8 in 32 bit mode I see Max as a rewire client in the Logic Library
Not so with Max 6.1.2 and Logic 9.1.8 in 64 bit mode. 64 bit mode is essential for this project….
Max says: "Registered Max 6 ReWire Device Please restart your ReWire mixer application" when ad-rewire is selected
But on any combination of starting Max and Logic Max says "ad_rewire: error starting audio. Is ReWire mixer running?"
I have tried:
Reinstalling Rewire
Reinstalling Max
Getting rid of all older Max versions
Trashing Library/Application Support/Propellerhead Software/Rewire
deleting and reinstalling Max 6.1.2
Deleting files in ~/Library/Application Support/Cycling ’74 and deleting and reinstalling Max
Putting MSPReWireDevice.bundle in Library/Application Support/Propellerhead Software/Rewire
Removing MSPReWireDevice.bundle from Library/Application Support/Propellerhead Software/Rewire
Deleting and re-reinstalling Max 6.1.2
Opening Reason hoping this would "inspire" Max or Logic
And all kinds of other stuff. Reason will open in "ReWire Slave Mode," just can’t get Max to show up as a Logic ReWire client

*I can get MTC via a combination of [midiin] and [sysexin] and MIDI rt via [rtin] into Max from Logic no problem. I seek detailed (timesig, tempo change, maybe basic start/stop/pause/continue commands via [hostcontrol~] and higher ppq) transport info that Logic’s MIDI clock (at 24 ticks per beat) cannot provide. When functioning with Max 6.0.8 and Logic 9.1.8 in 32 bit mode [transport] with @clocksource rewire was matching Max at 480 ppq, and providing good tracking through tempo changes etc. I have considered workarounds using [rtin] but tempo changes are a problem.

Apr 20 2013 | 7:44 am

Here’s what adrewire@.txt says:
max v2;
dsp prefsr 0;
dsp prefiovs 512;
dsp prefsigvs 64;
dsp takeover 0;
dsp cpulimit 0;
dsp optimize 1;
#AD version 20040504;
#AD nummidiports 1;
Mostly just settings, is the #AD version useful?

Apr 20 2013 | 8:45 am

After an endless cycle of trying everything the latest time I:
Made an alias for MSPReWireDevice.bundle and put it in Library/Application Support/Propellerhead Software/Rewire
After a while it started working.
Definitely had done those things before.
Is this at all a Max thing or all about ReWire?
Any tips to improve stability?

Jun 18 2013 | 12:06 pm

I have the same problem. I always get "ad_rewire: error starting audio. Is ReWire mixer running?" when i try to enable the audio.

I use the latest version of max msp and reason 6.5 on Lion OSX. I reinstalled max and reason, tried 32 as 64 bit versions, deleted the rewire directory and reinstalled it, symbolic link, … no success.

I tried the patch from max helper as patches of the
ReWire Essentials, Part Two page, but same errors.

Is rewire buggy in max msp ?

Mar 25 2014 | 12:20 pm

I’m in this problem with 64 bitversion too.

I’m slaving max to ReNoise

Max 6.0 to Renoise 32 bit works fine.

Max6.1 (in either 32 or 64 bit mode) to ReNoise (in either 32 or 64 bit mode) fails.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP