Forums > MaxMSP

Building Application

Jun 10 2010 | 11:49 am

I’m trying to make an application-build from Max 5.1.4 on a Mac OS X 10.6.3, but when I start the app, I get this error:

(mxj) Unable to find max.jar! mxj is rendered powerless in its absence.
Unable to create JVM

I’ve tried all of the suggestions of – but I just get new errors… often it’s something about:

(mxj crossloader) dynamic classpath entry /Contents/support/classes/ does not exist.

What to do? Please help, I really need this app up and running!

Jun 10 2010 | 4:06 pm

I’ve located the error to the occurrence of this object (with these parameters):

[mxj net.udp.send @address @port 54321]

I’ve tried everything, both in terms of including files in the build and manually putting files in the app-folder afterwards. Nothing seems to work.

Can’t anyone give it a try for me?

I’ve attached the very simple patch.

  1. Test.maxpat

Jun 10 2010 | 4:15 pm

instead of "mxj net.udp.send" try "udpsend 54321"
Works for me

Jun 10 2010 | 4:32 pm

Cool. I’ll try it out.

Jun 13 2010 | 6:57 pm

When using the udpsend only the first word of my list is send from Max (only one arrives at the destination – where the using the mxj net.udp.send sends the whole list)…

Any ideas or suggestions? Help, please! :)

Jun 13 2010 | 7:17 pm

Found out myself – a [tosymbol] before the udpsend, and everything was fine! :D

Jun 14 2010 | 11:08 am

you shouldn’t have to use tosymbol. sending a list/message works fine here with the help file for instance.

Jul 16 2013 | 7:24 pm

I have my random object in the init folder as rand.mxo. They work perfectly in Max 6.1.3 but when use them in a patch and build an application they cannot befound. I have already tried including them specifically with "include file."

Your can download them from here…

Viewing 8 posts - 1 through 8 (of 8 total)

Forums > MaxMSP