confusing names in pattr inspector
In the pattr inspector, both the name and varname attributes are described as "Scripting Name". Wouldn’t it be better to call @name something else, like "Pattr Name"?
It would be good to be consistent with pattrstorage, which calls it "name"
They are, in fact, the same. "varname" is the box attribute, "name" is the pattr object attribute. But you’ll notice that changing one changes the other.
Jeremy Bernstein schrieb:
> They are, in fact, the same. "varname" is the box attribute, "name"
> is the pattr object attribute. But you’ll notice that changing one
> changes the other.
but then they wouldn’t need to show up twice, one would be fine and less
OK, I’ll get a top-level task force working on it immediately. I would really hate for there to be a confusing minor detail in MaxMSP.
Quote: Jeremy Bernstein wrote on Mon, 23 June 2008 22:59
> They are, in fact, the same. "varname" is the box attribute, "name" is the pattr object attribute. But you’ll notice that changing one changes the other.
Ah… I guess I never used thispatcher scripting with pattr so I assumed they were different. I only brought this up because I thought it was a typo.
Max 5 learned me something new ;)
The difference is that one (varname) is an attribute of the box, and the other (name) is an attribute of the object. In Max 4, there was no difference (for the user) between the box and the object, and boxes had no attributes, so this was envisioned as a way to assign a pattr object’s box a name, without having to do it via the Max 4 ‘Name…’ dialog.
In Max 5, the difference between object and box is slightly more pronounced, and boxes have their own attributes. Such as ‘Scripting Name’.
I’m a little loathe to remove one of the two attributes, since there may be applications which depend on the one or the other. Undocumenting the object’s name attribute, while leaving it active, is a possibility, but has other downsides (like lack of documentation of an important feature of the object). So, until I have a better solution, sorry for the duplication in the Inspector.