Forums > MaxMSP

connecting DDR pad to max

Nov 26 2007 | 6:56 pm

hey, i am doing a project involvinv sensors and max, and i want to be able to connect a DDR pad to max to be able to use the sensors within it. i have tried to use the old insprock and hi externals, but i’m getting the "old CFM externals disabled" response. is there anything else that i can use? maybe a newer version of insprock, hi, or a new external? if anyone could help me out that would be great. thanks!

Nov 26 2007 | 7:12 pm

Hi Dave,
First off, what version of MaxMSP are you using? Since it sounds like
you are on an Intel Mac, you should be using the latest version of Max,
which includes a native version of "hi". You will need to lose whatever
old version of the object you may have installed. A friend of mine was
able to connect a USB DDR pad to MaxMSP with little effort, using the
"hi" object, so this should be possible.

Andrew B.

Nov 26 2007 | 8:31 pm

thanks for your respond! i checked and i did have the newer version of "hi". apparently i never checked to see if i did and downloaded the older version, and max was reading off of that the whole time. so i have the patch up, but it’s still not working. i am just using the patch in the help file. we are using a PS2 DDR pad with a PS2/USB connector connecting it to the computer, and it shows up on the device dropdown, but there are no outputting numbers. the pad is powered, and red lights show up when you step on it to show that it’s sending a signal, but still nothing. maybe it’s the pad itself? or the connection? thanks for your help!


Nov 26 2007 | 9:23 pm

Hi Dave,
You might find the following article to be helpful in working this out:

You are probably not polling the "hi" object in your patch. Note that
the object will not put out any numbers until it is polled.

Andrew B.

Nov 26 2007 | 11:53 pm

hey andrew,

yeah that link is where we got our patch from. i tried both the polling as well as a metro with a bang of 10 ms, but both didn’t work. i’ll keep working on it to try to figure it out, but if nothing happens, then it must be the pad. thanks for your help!


Nov 28 2007 | 7:06 pm

hey andrew,

i just want to say that it was the pad that wasn’t working. i went out and got a new pad for pretty cheap and it works fine now, so thanks for all of your help!


Aug 24 2008 | 12:34 am

Hi Dave,

Which pad did you end up buying? I just bought a Mad Catz DDR pad and I can’t get HI to see it on my Macbook. Really frustrating. Did you have to install a driver by any chance?


Aug 24 2008 | 4:00 am

this is the pad that we bought, i don’t know if it’s the same or not. we ended up tearing it apart and just used the motherboard inside and soddered wires to certain parts of the motherboard. then we used a ps2 to usb connector to connect it to the computer. we just used the help menu of the "hi" object. once you open it, you have to press the info button to send the pad’s information to the computer, then menu to set it in the menu of selectible items. then press "poll 10" to output the data every 10 ms, just like a bang, and you should be able to extract your data. if you need any help, just let me know


Aug 24 2008 | 4:03 am

I will be out of the office from August 7 until August 25 and will not
have access to my email account. If you need assisitance while I am away
please contact Ana Varas at 754-321-2050 or

Thank you

Aug 24 2008 | 4:26 am

Hey thanks for the info. I think I will have to pick that one up, I bought the Xbox360 version, since it is already a USB connection, but HI won’t see it. And I think this is because the pad is searching for which controller to connect to on the 360 (it can be one of 4 controllers). the power light flashes on when I connect it to my mac and then it quickly shuts off.

I am going to take it back and exchange for the universal one.

Thanks for the help!


Viewing 10 posts - 1 through 10 (of 10 total)

Forums > MaxMSP