Forums > MaxMSP

Constant need to rescan for MIDI

Jul 19 2009 | 9:31 pm

Has anyone else experienced this or does anyone have a suggestion. I’ve been having a problem where my machine constantly drops MIDI communication and I have to open up the AudioMIDI setup and and rescan for MIDI frequently. This occurs numerous times during a given performance and is making everything rough going for me.

I’m using MaxMSP 4.6 on a MacBook Pro running OS 10.4.11. Any thoughts would be greatly appreciated…

Pamela Z
Composer/Performer | 415 861 EARS (415 861 3277) | mobile: 415 5PAMELA (415 572 6352) |

Jul 22 2009 | 8:51 am

Hi Pamela
Really need a few more details re your setup . .
Also if on Mac, open up the Console app and try and recreate the crash, hopefully an error log will be generated to look at.
What sort of interface are you using,and what’s it doing?
Are you trying to send or receive a lot of midi data?
Have you confirmed the cabling is 100% – I have had problems with extension usb cables before that caused dropouts till replaced.

Jul 22 2009 | 10:05 pm

Thanks for responding.OK, so my setup:
As I said in my previous post I’m using MaxMSP 4.6 on a MacBook Pro running OS 10.4.11. (So yes, Mac.)
There’s no "crash" to recreate. It’s simply a matter of loss of MIDI communication from one of my devices.
I’m using a MOTU Ultralite (FireWire) for Audio and for one MIDI source (which doesn’t lose communication at all.)
I’m using A MOTU Fastlane (USB) for the other MIDI source (which is the one that drops communication.)
I’ve been using this set-up for some time now with no trouble, but in the past couple of months, I’ve had increasing problems with loss of MIDI communication from the device connected through the USB interface. I’ll be performing a piece and then suddenly no MIDI. I quickly open Audio MIDI Setup (while still in the midst of performing the piece) and click "Rescan". MIDI is then recovered and I finish the piece. Since the problem doesn’t occur with the MIDI device that’s connected through Firewire, I wonder if it might be something to do with a problem with my USB connection. (I’ve tried different cables already, btw.)
Thanks! P

Jul 22 2009 | 10:51 pm

I had problems on a MacBook Pro with MIDI controllers plugged in to the USB ports on the right hand side of the computer. The symptoms were very similar to what you describe – I would lose MIDI communication, and it would be restored by restarting the app (it didn’t seem to matter what app – Live, Max, whatever). I don’t recall if rescanning would fix things.

Any MIDI controllers plugged in to the USB ports on the left hand side of the machine worked fine. I found that using a bus powered USB hub on the right hand ports and plugging the interfaces into that fixed the problem.

Could be something similar….



Jul 22 2009 | 11:10 pm

** edited out; misunderstood the problem **


Jul 22 2009 | 11:12 pm

OMG Brad! Thank you for that info. I just started trying the left port earlier today and it hadn’t dropped the MIDI yet as of this writing. I just assumed it was a fluke, and that soon the dropping would re-commence. Now that I’ve seen your post, I’m convinced that this has probably solved the problem! Now I’m going to try using a hub on the right. I’ll let you know the results. Weird! Do you think it’s the actual USB architecture in the MacBook Pro that’s at fault?


Jul 22 2009 | 11:22 pm

Wow this is weird. It sounds like the problem is kind of wide spread. Is it also the right USB port that gives you this trouble? I wonder if the problem only exists on certain Machines. I have two Mac Book Pros. One is a Model 3,1 and the other is a Model 4,1. I don’t have the problem with the 4,1, only with the older machine.
I’m curious if other people experiencing this have the same machine. (In the System Profiler it says MacBookPro3,1 under "Model Identifier".)

Jul 23 2009 | 12:16 am

It was definitely the right side port. And, yes, this does seem to be a known issue. I do recall finding information about this in the Apple discussion groups. Sorry, I no longer have the machine it was happening on, so I can’t provide the model number.


Viewing 8 posts - 1 through 8 (of 8 total)

Forums > MaxMSP