Forums > Max For Live

Currently running max/msp has wrong architecture


March 26, 2013 | 12:38 pm

hi

I have live 9 and max 6.1 32 bit installed but when i want to edit a device in max for live i get this message in live status bar, "Currently running max/msp has wrong architecture – expected 32bit, found 64bit " max lunches anyway bit very unstable and crashes !
anyone has a solution for this ? i installed max 64bit but uninstalled it before installing the 32 bit version

March 31, 2013 | 8:29 pm

Same problem here. I tried unchecking and rechecking the "Open in 32-bit mode" option in the finder, but I’m still getting the same message. My plugs don’t even open in Max… Would be very grateful for a solution.
I’m on Mac, by the way… Don’t know if that makes a difference…

April 1, 2013 | 1:30 am

OP – please supply system details. If you believe you have the versions matched then please email full details into support.

Mac MFL users – please make sure you have all Live installer DMGs unmounted. Please note the Mac version of Max 6.1 is FAT – both 32 and 64 bit versions are installed from the same installer.

If this is not it, then please email all details into support

-A

April 1, 2013 | 7:10 am

Hmmmm…

I downloaded Live 9.0.2. to see if that would make a difference. Which it certainly did, but not in a good way: Now every time I try to load any m4l plugin Live crashes instantly. I’ll get in touch with support to see what the hell is up…
System: MacBook Pro 2.66 GHz i7, OS 10.8.3., Max 6.1.0

April 1, 2013 | 7:18 am

Solved! I updated to Max 6.1.1, and now everything seems to be back to normal again, including being able to edit plugins in Max…

January 6, 2014 | 6:54 pm

I am new to this and having the same problem. Should I just install the 64 bit version of Max instead? will this solve the problem? I’m aware that it has not been fully developed yet.

February 16, 2014 | 2:29 pm

hi! i had a similar problem here. i had to install max 32bit to use some 32 bit objets. but since i did max 4 live wont open any plugin. it says that "the selected application max couldn’t be charged. a 64 bits version is probably requiered. can’t i run max for live with my 32 bit max?

February 17, 2014 | 11:32 pm

Yes you can !

February 16, 2015 | 7:20 am

I’m actually having a problem with this using Live 9.1.7 and Max 7.0.1. I’ve had the ‘expected 64bit, found 32bit’ message recently and then reinstalled everything to try and sort it. Today, having had no problem all weekend, I’m getting the above message again. It’s a pain and probably means I should use Max 6 in Live in order to edit devices for the moment.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > Max For Live