Forums > Dev

Debugging in XCode

Dec 05 2009 | 7:11 pm

Hi Guys,

I am having no luck debugging the examples in XCode.

I build the development build of an example project

I add the max runtime as a executable using Project->Set Active Executable

I build and debug in XCode

I load a test patch using the external into the runtime.

Breakpoints are never hit and they are orange in the debugger.

Am I missing something



Dec 05 2009 | 9:29 pm

Make sure that you use a development build. You might also want to make sure that there’s no optimization done by gcc.

Dec 06 2009 | 9:41 am

Hi Emmanuel,

Thanks for the post, definitely doing a dev build with no optimisation.

I am going to try to set a project up from scratch and not based on the example code to see if I can get that going.



Dec 06 2009 | 10:56 am


Made a project from scratch and debugging works fine!


Thanks for the help


Dec 07 2009 | 2:11 pm

Sometimes this can happen if the executable is set up and then the path to executable changes.


Dec 19 2009 | 5:46 am

Also try this.. first put a breakpoint directly in the main function… I often find that if I don’t do this all my break point are ignored.. But if I put a breakpoint first in the main then all my other break point works…

I hope it help!


Apr 22 2010 | 8:05 pm

Do any of you guys know why I have no options, when I choose Project->Set Active Executable from the menu? I have put it on development build as you suggest, but nothing pops up

Apr 22 2010 | 10:07 pm

go in Project->New Custom Executable and choose Max/MSP Runtime

Apr 23 2010 | 10:46 am

That did the trick. Thanks Andrea!

Oct 21 2010 | 1:35 pm


1) I’am learning to write externals using Xcode 3.22 on Snow Leopard.
When build an object from the example folder (SDK 5.1.1) all seems to be fine. No messages error.
2) Then I’ve upload the file path from Max to the SDK Exmaples Folder,
3) When I try to load the new object, typing from Max, it appears from the autocomplete,
4) When it must be instanced by Max I receive from the Max windows the message: newobj bang: No such object.
5) I get always the same problem for any new object

Unfortunalty there are not examples on how to setup Xcode 3.22 on the web for Max externals so I’m blocked on this simple level.


Viewing 10 posts - 1 through 10 (of 10 total)

Forums > Dev