Forums > MaxMSP

Dirty sound with AK5370 microphone

Jul 24 2009 | 8:47 pm


I wonder if anyone else has had this problem.

I am testing patches with a Logitech AK5370 usb microphone. After about one minute the sound becomes dirty and full of clicks until sound is restarted. Then I get just another minute of pure sound.

This happens for any patch with microphone input, like a simple patch with 8 different delays. There are no other choices than 44100 for sample rate, both in DSP status and Audio driver setup, so I can’t know if the microphone is using a different sample rate.

The microphone is new and doesn’t seem to make any noise in skype. It didn’t work at all in MaxMsp 4.5, and the upgrade to MaxMsp 5 didn’t solve the problem. I have the same problem also with no extra externals installed.

I have tried this both on an ibook G4 1.33 Ghz 768 Mb ram, and a macbook 2.16 ghz intel 1 GB ram. It made no difference, but both were running Osx 10.4.11.

Hope someone can help.


Jul 24 2009 | 11:19 pm

have a look at your dsp settings

small vector sizes may be the problem

Jul 25 2009 | 12:58 pm

I have tried with different vector sizes. Even the largest just temporarily cleans the sound, then it will keep getting more noise the longer the sound is on.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP