Forums > MaxMSP

does max6 standalone need "java-runtime"

Apr 14 2012 | 4:06 pm

hello c74 pros,

i have made a standalone with the current max6 for mac on mac osx 10.6.8
it works fine on this machine.

if i boot the same machine into 10.7.3 the operating system tells me,
that i need to install "java-runtime" to run my standalone.

i did not use java in max ….
does max6 standalone need "java-runtime" to run ?

i get the same error message for standalones made with max5.

is it a bug ?

Apr 16 2012 | 1:02 pm


i did some more tests.
even a standalone with a single bang inside does require the "Java Runtime"
on mac osx 10.7.3

same result, if i build the standalone in max 5 or max 6.

i did a clean, fresh install of osx 10.7.3 on an empty harddisk.
i do not understand why i need java to run a standalone.
or is max based on java ?
i thought, if i make a standalone, it runs without installing anything.


Apr 16 2012 | 2:18 pm

Hi lee,

never had this bug. but one thing that comes to my mind (though it might be the totally wrong path) is that i read theses days that apple deactivated Java (as part of a recent update) due to a security issue that was exploited by a virus.
so my far fetched thought is: as usually Java is installed and enabled on all Macs maybe Max expects it to be installed/active even though it is not used….

Does the error only occur on standalones?

But that would be probably more a question to support…

(unfortunately my Mac is of an older generation and I can’t reproduce the error)


Apr 16 2012 | 3:19 pm

hello jan,

the error accurs also with the max 5 standalone application.

steps to reproduce:
– install latest mac osx 10.7.3
– install max 5 runtime
– try to start max 5 runtime
-> you will get an error (installation of java runtime)

the max 6 standalone opens fine, but any standalones made with max5 or max6 does not open. (even if only one bang object is inside …)


Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP