Forums > MaxMSP

Edgeblend between projectors

Aug 06 2013 | 2:38 am

Hello I am trying to create a solution for edge-blending between several projectors.
I have come this far, but I do not understand why it is not working with

I get some images out using, but I would like to use hap.

What Im I doing wrong?

-- Pasted Max Patch, click to expand. --


Aug 12 2013 | 8:39 am

looks like it’s simply a typo.
you have " sub-node.ctx" rather than "sub-node-ctx"

Aug 12 2013 | 12:47 pm

Still wont let me capture to the node. Should I not enable capture parameter for the node?
I might be confused of its function.

What I want to achieve is:

1. send several textures to individual objects.
2. Capture all of these textures by a object
3. send the combined texture to two or more objects for overlap and edgeblend when using several projectors.

But when I enable capture, everything goes black…….

I thin I have misunderstood some concepts here? or?

Thanks for you help.

-- Pasted Max Patch, click to expand. --

Aug 12 2013 | 3:23 pm

your patch works perfectly over here with the latest 6.1.3 on the Mac.
although i don’t have your gl.edgeblend shader, so i can’t really say what that’s doing.

if you still can’t get it to work, please post your relevant system specs.

Aug 12 2013 | 10:46 pm

Hello Rob,
After trying out the different shaders with edgeblending I still get no image. I removed all edge-belending objects, and still no image.

I have Max 6.1.3
Running on OSX version 10.8.4
Processor 2.6 GHz Intel Core i7
16 G Ram
SSD hardrive
Retina display mac.

My latest try:

-- Pasted Max Patch, click to expand. --

Aug 13 2013 | 10:30 am

when i start your patch, i see the following (attached as an image).
you see something different?

try replacing the gl.hap objects with a -> gl.slab combo.

what is your graphics card?

  1. Screen-Shot-2013-08-13-at-1.24.49-PM


Aug 13 2013 | 10:49 am

This is wired. I just did a re-install of my computer. Everything from scratch, and now I get the same image as you………

go figure….

Problem solved.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP