Forums > MaxMSP

Elasticx~ inside a poly object?


Aug 20 2009 | 4:32 pm

Has anyone tried putting a Elasticx~ object inside a poly? If so what are your results? Did it behave weirdly? I’m having some troubles that just isn’t coherent. would like your feedback as well?

Aug 20 2009 | 6:49 pm

I’v been trying to use the Elasticx~ inside a poly~ for a while, but it seems that it is something wrong with it.
I cant figure it out. I’m 90% sure that it’s not my code thats the problem. It seems that the some of the instances do not update if I turn the Elastic on and off. It’s like it turns off some of the instances but not all of them. Like the Elasticx~ object toogle feature for groove or Elasticx fails to update itself inside a poly.

Here is an example. Play with a midi keyboard, and trun on and off the elasticx, then play from the lower key tho the high key. Please let me know if you get the same result.

I’m on a Macbook Pro 2.4GHz core 2 duo Leopard ver: 10.5.8

Main Patch:

— Pasted Max Patch, click to expand. —

Poly patch: Save as rdp.voices.poly-subpatch.maxpat

— Pasted Max Patch, click to expand. —
Nov 17 2010 | 11:04 am

anyone has found an answer to that? I also have a lot of problems using elastixc~ within a poly~….

Nov 17 2010 | 4:34 pm

I had problems yesterday too. On my MacBook Pro a simple patch suddently needed more than 90% CPU because of elasticx~ (no problem on my iMac). I had no time to check what happened but replacing elasticx~ with a groove~ followed by a gizmo~ solved my problem.

The strange thing is that I used elasticx~ extensively on the same laptop in the past, without real problems.

p

Nov 17 2010 | 4:42 pm

strange object so with some bugs it seems….did u ever use it within a poly~ ??

Nov 17 2010 | 4:50 pm

I successfully used elascticindex~in poly~, but never elasticx~

Viewing 6 posts - 1 through 6 (of 6 total)

Forums > MaxMSP