Forums > Dev

Error 14001 loading external

Feb 27 2009 | 2:49 pm


Im currently using vista home basics.
I’ve installed maxmspsdk and max msp 4.6, but since my laptop does not have visual studio installed, i’ve copied the externals from the pc to the external folder in cycling74max4.6cycling74externals.

but when i run my patch, error 14001 will appear, saying that it’s failed to load the external.

Any idea on why it occurs and how to solve it?

I did copy using the same method before to my desktop(it doesnt have visual studio installed either), but everything works fine.
my desktop’s windows xp.

could it be due to vista? is there additional step or any other platform that I need to install first?

Feb 28 2009 | 12:46 pm

One potential issue with Windows seems to be the eternal DLL bedevilment. In particular, you may find that your .mxe’s run fine if the Debugging version of some DLL is available, but crash if only the plain-vanilla version is installed.

And Vista will have "enhanced" versions of various DLLs.

Have you tried googling MSN on error 14001?

Feb 28 2009 | 1:58 pm

I suppose we should have a section in the SDK docs about this. Here are some suggestions.

Check out dependency walker to see what other DLLs your externals depend on:

However, usually this issue is the Microsoft C runtime library. Here are some alternative fixes:

First, make sure to build release versions of your objects for running on other machines.

Then, assuming you are using MS Visual Studio:

1. Link statically to the MS C runtime library.

2. Or, install the "Microsoft Visual C++ 2008 Redistributable Package" (or an earlier version if appropriate) on any machine you want to run your externals on.

3. Or, use Max 5 and the Max 5 SDK which has the option of linking to maxcrt.lib to use Cycling ’74’s private build of the MS C runtime which ships with Max (maxcrt.dll).

Note that since Visual Studio 2005 the Microsoft C runtime lib links using special magic (side by side assemblies) so it is not enough to just have msvcrt.dll (msvcr71.dll, msvcr80.dll, etc). This has nothing to do with Vista.


Mar 04 2009 | 12:11 pm


but could the reason be due to the visual studio? or other things?

i’ve copied the same exact externals on another pc, and that pc does not even have visual studio installed (the pc’s XP version 2002), I merely copy the externals to the external folder in cyclying74,and there is no error at all.. & everything works fine..

Mar 07 2009 | 4:42 pm

I managed to solve the problems with the pc with VS 2005 installed in it.
I installed VS 2008 into that pc also, and everything works fine.

I think when I copied the externals into the computer and tried to run them, the linker somehow clashes with the VS2005, but now that VS2008 is in there, they don’t clash anymore.. That’s what I think..

as for the pc with Vista, I have no idea how to solve the problem, but it’s fine for now since I’ll just use the PC running in XP.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > Dev