Forums > MaxMSP

extremely stuck in a resample patch

Jul 01 2009 | 10:02 pm

i’m rebuilding the patch i use for preforming because the one i use now is quite buggy and way too messy to debug.

so the core of my patch is based on being able to sample things (played with a software-sampler or from the outside), process them in deifferent kind of ways and resample that.

now last weekend i began working on the resample part but i can’t get it to be accurate.

the patch is too big to explain but the problem is that when i resample audio the resampled loop moves. so after resampling 10 times the startpoint of the loop moved forward by one eight note wich is quite alot.
especially because i’m working on making my patch bug-free i wan’t this to be accurate as possible before i move on rebuilding.

i’ve been trying and looking at it for almost 18 hours(i’m not kidding this is why i’m quite desperate) in the last three days but i REALLY can’t figure out what goes wrong.
i hope it’s just something in the patch i oversee or i just don’t know.

can you please have a look at my patch, try to resample and give me tips about, or even tell me what is the problem.
i know it’s quite a complicated patch but there are only 3 or 4 steps to test wich i commented. i tried to make it very logic with the sends and receives but i will answer any questions as soon as possible.

Jul 01 2009 | 11:07 pm

sorry but i don’t have time to diagnose the problem properly

however i do notice you are using record~. i recently completed a project where i was using this. i found that it didn’t start and stop recording as quickly as i wanted it to, and was a little temperamental (may have been my massive patch).

I recently started using a combination of count~ and poke~ for a looper and it is very tight! I advise you to use these objects for your resampling

Jul 02 2009 | 1:51 am

i’ve timed the loops of the play object and the ‘smplq’ metro and the delay between the two seems quite constant constant. unless it would take the record object 3 to 4 milliseconds to process the recording that couldn;t cause it, wich wouldn’t be probable right?

Jul 02 2009 | 9:39 am

to be sure i just tried recording using count~ and poke~ but the problem stays exactly the same.
it’s a really big misery to me.

Jul 02 2009 | 10:08 am

FINALLY! i discoverd the problem: the subpatch i made for ducking when samplestarttime is changed caused a delay of a few milliseconds.
problem now is i don’t know how to make a system for doing that without causing delay.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP