Forums > Max For Live

file_path live api bumpity

Jun 09 2013 | 8:17 am

I wanted to start a bump thread on this new feature in the ableton API. I can call up the file path, even with freshly recorded clips, but the output is Unicode and removes slashes. Anyone figure out how to use it? I am new to max, sorry if its a silly question. Adding filepaths of large sample folders into max preferences makes loading time dreadfully slow, and fresh recorded clips prepend 000 on the filepath but not the name. This new feature is key to me, any help is much appreciated.

Jun 09 2013 | 9:36 am

I found conformpath but no dice.

Jun 09 2013 | 11:10 am

I can’t figure a sprintf or regexp for it. Please help, if its an API fix needed, ill be patient, would love to know from one of the wizards out there.

Jun 10 2013 | 6:08 am

Stray just pointed me towards your thread. Just discovered the same thing – Sorry for duplicating the topic.

If its any help (and it probably isn’t) it works fine under OSX.

Jun 10 2013 | 8:04 am

Thx for reply gav, seems to be on the windows end of the api. I’d think this would be a major new feature for alot of people to have access to fresh recorded clips. Hopefully we won’t have to wait too long.

Jun 10 2013 | 8:20 am

Yeah I was surprised it took this long for anyone to notice!

Jun 10 2013 | 10:53 am

Paths in Max use a crossplatform Max path syntax. The *.path refs detail this a little. It may not look exactly like what you see in Windows explorer, but it will still work fine.

Also, on Windows you can’t use any of the following characters in a file name: \ / ? : * " > < |

Let us know with exact path examples if you can show this is not the case



Jun 10 2013 | 11:20 am

Oh. well it doesn’t seem to work for me. Here’s a screengrab of the max window.

Maybe its the space. Hold on……

  1. Screen-Shot-2013-06-10-at-09.40.491


Jun 10 2013 | 11:57 am

Well I removed the space from the filename but not from my account name so its not exactly scientific.

But here is a screengrab from the device on OSX (which works).

It retains the "/" between each level of the file path and doesn’t throw an error.

  1. Screen-Shot-2013-06-10-at-19.53.54


Jun 10 2013 | 1:37 pm

Here’s a screen capture of the scenario I’m looking at, as if I recorded a new loop from the ableton library. You’ll notice the prepended 000 naming thing on the right side for recorded clips until the project is saved.

  1. file_path-and-name


Jun 10 2013 | 2:10 pm

Ok hold the phone.

Sorry, this is in fact a bug which has been fixed for 6.1.3, which should be released in a few days.

Apologies for the inconvenience



Jun 10 2013 | 3:36 pm

Thanks much for your input guys!

Jun 11 2013 | 8:50 am

glad to here it’s been fixed :)

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > Max For Live