Forums > MaxMSP

freeverb~ for max 6?

Apr 23 2013 | 1:35 am

Does anyone have a version of the freeverb~ external that will work with max 6 on mountain lion?
I’ve attached the one I have that last worked for me, but it doesn’t seem to be recognised by max now, and it appears as a folder in finder for me, unlike my other mxos.
I’ve tried compiling it, but to tell the truth, I stopped understanding how to use Xcode a few versions ago.
I found some gen solutions, but I don’t have gen.


Apr 24 2013 | 9:18 am

hi alex, i also just try to find a freeverb~ version that works with max6… but on a windows 7 machine. i got the same version as
you send. that one creates a lot of distortion, artefacts and finally results in crashing max (6.0.8) on win (xp and 7).
i tried the gen version, which works fine but it seems to be more cpu expensive than the external.

it would be very nice if someone could recompiled the freeverb~ external for the current versions of mac osx as well as for windows.
thanks in advanced, johannes

Apr 26 2013 | 1:22 pm

a much superior freeverb implementation is sitting right inside your max6 distro. i think since max 6.1.x you can just type

gen~ freeverb

into a new object box. otherwise just go to /Max6…/examples/gen/gen~.freeverb.maxpat. for me it is not expensive on cpu at all. keep in mind it uses 64-bit doubles internally, the original external does not.

you do not need to own Gen to be able to use gen~ patches. you only need to own Gen if you want to edit the gen~ patches.

not sure why you want to use freeverb though, unless for some crazy specific retro sound. it sounds completely awful and always has done. much better to use


or /Max6…/examples/effects/reverb/lib/yafr2.maxpat

both are much better general small cpu usage digital reverbs. all these reverbs work the same (very well) on windows, osx, 32-bit and 64-bit, etc

Apr 27 2013 | 11:13 am

thanks for reply, stkr.
on my mbp the difference is about 8% (fv~ 23% and gen~fv 30% cpu in the activity monitor) when running the help patches.
cioa, j

Apr 29 2013 | 7:52 pm

hi johannes,

just wanted to follow up on this. on my machine, and i have a really bad crappy old machine, i get ‘cpumeasure’ on a [gen~ freeverb] instance hovering around 0.01 %, max ‘cpu’ monitor around 1.1 %, and in ‘activity monitor’ a jump of around 4 % when engaged (max sits at about 7 %, with gen~ freeverb around 11 or 12 %).

maybe something is bad with your machine / settings? what are your sig vec size & i/o etc? mine are quite hardcore.


Apr 30 2013 | 1:59 pm

hey stkr,
i have a mbp quad core, about one year old with 256 gb ssd and 18 gb ram. my settings: io vec 512, sig vec 256, sio on, iai off
hm, i guess that my cpu % refers to the utilization of only one core which is used for the dsp processing?
but iam not sure… cioa j

Apr 30 2013 | 11:40 pm

@stkr ah okay, I didn’t realise I could use them without gen. Cheers.
However, whenever I create a gen~.freeverb object (or any gen~ object for that matter), my max just crashes without any errors or anything :/
Any ideas?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP