Forums > MaxMSP

Gigaport HD / MaxMSP / Asio issue ?

May 22 2010 | 7:21 am


I can’t get the Gigaport to work properly with Asio-drivers in MaxMSP (or any other ASIO-compatible program (like Wavelab) I’ve tried thus far).

When I select the ASIO driver as DSP-device it doesn’t return any I/Os (it shows I/Os for previous selected driver) and when I try it via directsound (Gigaport Multi/8ch as output device) it returns only 2 outputs. Instead of 8.

So my question(s):
1. How do I get the Asio driver to work properly?
And specifically: how do I get it to work properly in MaxMSP?

2. Or is there another way to access all 8 outputs, for example via directsound? (which I’d rather not use since Asio is more efficient)

Windows XP SP2, ESI Driver 1.1.0
Pentium Core2Duo E7200 (2.53Ghz), 2 GB RAM DDR2 800Mhz, Asus P5K Mobo
Other soundcards installed: Audiotrak Maya44MK II, Realtek HD Audio (onbrd)

Also tried it on:
Windows XP SP2, Pentium 4 Northwood @ 2.8 Ghz
Windows 7 x64, Acer Aspire 3810TZ (laptop, ESI Driver 2.0.0)

May 22 2010 | 7:22 am

Btw: With Gigaport I mean: ESI Gigaport HD

May 25 2010 | 4:27 am


Well, MaxMSP does seem to be the problem; after contacting technical support I've managed to get the soundcard to work in WaveLAB using the ASIO driver. So the driver does work.

But MaxMSP still thinks it doesn't.

This is what I do:
– Connect USB soundcard
– Start MaxMSP
– Open DSP Status
– Select ad_asio ASIO 2.0 – ESI Gigaport HD driver

Result: (also see included image)
Sound won't turn on, Gigaport does not return ANY inputs/outputs, samplerate, etc. Depending on what driver was selected before I selected Asio it will either leave everything blank (no driver was selected) or the values of the previous selected driver never change.

Having directsound or mme selected and sound on, selecting the asio driver also turns off audio and the driver-umenu reverses to it's previous selected driver. It stays somewhere in-between though, for any further changes I make at this point in the DSP Status are ignored. Re-selecting the driver (in this case directsound) gets it to work again.

Max-window does not report any errors. (It does when I try to select Asio driver when the soundcard is not connected via USB). Is there a logfile where I might find some clues?

I've tried Asio4All as a workaround and it does enable me to use all 8 outputs. I'm not sure about CPU-usage and latency though.
Besides, I bought an Asio card because I figured MaxMSP works best with it.


  1. asiowontwork.jpg


May 25 2010 | 4:47 am

Lol, my question(s) would be:

Anyone else had this problem with Gigaport HD and MaxMSP (or any other asio soundcard) ?

Anyone know of a solution?

PS: I’m running Max 5.0.8 because that’s what they run at school. The technical support guy hasn’t had time to update all machines yet and of course I don’t have access.
Might this be a bug that is already fixed in later versions?

May 28 2010 | 4:19 am

Any chance you have to change the sound input/output under System Prefs?

May 28 2010 | 11:51 am

Well, here’s my last post on the subject: DON’T BUY a Gigaport HD if you’re planning on using it with MaxMSP. I just bought an ESI U46 XL and it worked immediatly. It is also E10,= cheaper where I got it, though it has lesser outputs (6, not 8). On the other hand, it has inputs (4 total), one of them being a 48V amped XLR connector for microphones.

Still, it’s weird the Gigaport HD has trouble with Max (or the other way around) since the U46 XL is from the same manufacturer. Not sure where the problem lies (ESI or Max) but I’m finished trying to fix it ;)

Aug 08 2011 | 3:22 pm

Has anyone figured this out in the past year? Just got a Gigaport and have encountered the same problem.

Aug 08 2011 | 5:40 pm

Hello. I’m using the ESI Gigaport HD with no problem in Win XP and Win7.

The only error I get entering the ad_asio ASIO 2.0 – ESI GIGAPort HD is
• error: ad_asio: ASIOGetClockSources() returned 1.

but that does not affect the eight separate outputs of the soundcard.

I’m using dac~ 1, dac~ 2, dac~ 3….dac~ 8 for outputs and green leds lit as signal passes through the soundcard.

Try different drivers. I you want let me know and I will send you the drivers I use.

I’m using MAX/MSP 4.5.

Kind Regards,

Nov 12 2011 | 4:28 pm

hi, i had the same problem as REJH (see above). my solution: install the "esi gigaport-driver", get the "asio4all-driver" (, install it and select in the properties of "asio4all" the "giga hd multi-8ch" as audio-device. now select in the dsp-configs of max the "asio4all-driver". that’s it, including 8-channel-i/o-mapping which works fine!

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > MaxMSP