Forums > MaxMSP

glitchless VST outside of Max can be clicky when used with [vst~]


Feb 25 2014 | 2:47 am

Hi there,
I’m using a Reaktor ensemble as VST in Max.
I noticed the global event loop in Reaktor seems clicky: sometimes there is one clicks. Almost regularly.

Please don’t tell me to port the patch to Max. That could be a solution in the future, but not now.

Is there a way to optimize the integration/execution of a Reaktor ensemble as VST, or more globally a VST in Max ?

Did I forget about something somewhere …?

Any help would be very appreciated :)

Feb 27 2014 | 2:42 am

any ideas ?

Feb 27 2014 | 5:43 am

I use Reaktor (and many other VSTs simultaneously in max 5 with no issues. However have you checked CPU utilization and have you checked your buffer length (latency) that Max is using)

Also, I’ve found that different audio interfaces can have an impact. I just switched from MOTU to RME last month and I’m able to work with lower latency

Feb 27 2014 | 5:49 am

it doesn’t seem to be a latency issue at all.
the same VST outside Max runs fine with my RME, even with my built-in output etc.

digging more…

Feb 27 2014 | 9:00 am

What version of Max?

Feb 27 2014 | 9:18 am

6.1.6

Feb 27 2014 | 12:33 pm

Can you try running 5.1.9?

I’ve had a lot of grief with Max 6 but max 5 has been essentially flawless. It’s been hard to get test cases to the cycling74 team so it would be interesting to see if someone else experiences the same behavior with Max 6 vs max 5 when running VSTs

Feb 27 2014 | 12:36 pm

That would require to reinstall 5.x and "compile" it to an standalone in my case. why not…

Feb 27 2014 | 12:55 pm

testing on tomorrow.
seems good on my laptop with 5.1.9 … curiously ;)

something more (and bad), using it on the production version on 6.1.6 running as 32bit … that SHOULD be 64bit, btw.

Feb 27 2014 | 3:38 pm

If you have a Reaktor ensemble which is glitching in vst~ please send it in to support

Cheers

-A

Feb 27 2014 | 3:42 pm

@Andrew, testing at first to run my max standalone packed for 64bit.. which should have been the case! Then, doing that if it still doesn’t work fine.

to be more precise: these are not massive glitching.. just sometimes (not every time at the same moment, but about each 1 minute, there is a small click)

Sep 04 2014 | 2:03 pm

Hi all,

I’d like to reactivate this thread, as I am experiencing similar problems using Reaktor in a vst~: actually all ensembles loaded in Reaktor inside Max on my machine are clicky. As Julien says, clicks appear not really often, but they are quite audible. In my patch, the vst~ is inside a poly~ with one voice (just to be able to mute the dsp chain, as the subpatcher contains many other signal objects). The clicks were initially more frequent, but I discovered that adding "@parallel 1" to the arguments of the poly~ actually helps. But does not solve totally the problem. I don’t have such similar problems with any other vst plugins I use (also from Native Instruments). I’m gonna troubleshoot more, but if some other users had similar problems and have tips, there are warmly welcome!

Best,

Alexis

Computer: Macbook Pro i7 2.7 GHz
System: 10.9.4
Max: 6.1.8 in 32 bits (I had similar issues before with 6.1.6 and 6.1.7)
Reaktor: 5.9.0

Sep 05 2014 | 10:25 am

A) What buffer size/latency settings are you using in Max? Have you looked at the CPU utilization reported by Max? Is it high?
B) Have you tried your patcher in Max 5.1.9 — I use Reaktor in that environment all the time and it’s totally glitchless.

Sep 05 2014 | 12:32 pm

hi dhjdhjdhj,

I’m working with buffer sizes of 512 samples (I/O) and 256 (signal), and I have absolutely no problems with CPU, it runs between 10 and 20%. I did not try this patch in 5.1.9 because I simply cannot, I use too many features from Max 6.

Alexis

Sep 05 2014 | 12:45 pm

Not sure whether this is helpful but I went through a period of time where I had audio glitches that I thought were CPU or VST~ related and it was only months later that I realized that the problem was actually due to signals that ended up being too loud and overloading the DSP. (Too many signals being summed to the output)

Sep 05 2014 | 11:43 pm

It seems weird that a too loud signal can overload the DSP: signals are computed anyway in float64, so even a +200dBFS should not be harder to manage for Max than -200dBFS. But if you have tons of cables connected to the same output, it has to perform as many sums, so that maybe could charge the CPU more (even if a sum takes really little CPU).

Sep 06 2014 | 5:04 am

Nothing to do with overloading. As I understand it , legitimate values sent to the DAC are those between 0.0 and 1.0. But say you are summing multiple signals and at some points in the cycle you get a value that’s greater than 1.0. That value will be clipped if sent to the DAC hence won’t faithfully represent your sound, i.e. distortion.
I first ran into this when I had a lot of VSTs running simultaneously and so I thought the CPU wasn’t handling them well. Then I noticed that reducing the internal gain (and increasing my analog amp gain) resulted in no distortion.

Not saying that’s what’s happening to you but perhaps just worth checking

Sep 06 2014 | 12:17 pm

I see, I did not really get your previous post. No it’s definitely not distortion, it’s clicks, that occur every minutes or so. The clicks occur only if there’s signal coming out of Reaktor. Not sure if they come from a discontinuity in the signal (a buffer or a few samples being lost or something similar), as I did not have time to record and observe it, but it sounds like that.

Alexis

Sep 16 2014 | 4:23 am

Hi all,

I did further checks, and actually the problem does not come at all from Reaktor, but from vst~, which becomes clicky during parameter changes. This problem, that does not occur on Max5, has already been addressed in another post:

http://cycling74.com/forums/topic/vst-parameter-clicks/

The bug is known and has already been ticketed. I hope it’s gonna be solved soon, it’s too bad because it currently really limits the interest of hosting vst plugins into max.

Alexis

Sep 16 2014 | 8:08 am

actually, the original post wasn’t exactly that "bug"
no parameters change would drive into clicks as well..

Sep 16 2014 | 11:05 am

The last reproducible bug had to do with parameter input, and is definitely fixed in 618.

As always, we are really interested in reproducing these issues, so if you have a way of getting your projects to us we’d very much appreciate it

Cheers

-A

Sep 16 2014 | 11:28 am

Hi Andrew,

Here it is, the bug is as isolated as it can be, I hope my comments are clear enough:


-- Pasted Max Patch, click to expand. --

Best,

Alexis

Sep 16 2014 | 5:28 pm

Don’t get me started on max6 VST~ problems that don’t happen in max5. I think I’m going to be stuck with Max5 forever

Sep 17 2014 | 8:34 am

@alexis

Thanks for that. Obviously something is not right here. We shall dig in to it.

-A

Viewing 24 posts - 1 through 24 (of 24 total)

Forums > MaxMSP