Forums > MaxMSP

Help… text: can't find file problem

Apr 13 2008 | 7:10 pm

Hi all,
I’m making a Max patch that needs to drag and drop files onto a dropfile and then load the file up into a text object to do processing/converting.

When I simply prepend "read" to the output of the dropfile and connect it to the "text" object, it can’t find the file… well it’s right there in the place where it can’t find it… So I tried using "conformpath" to convert the file path into another format and what ever format I put it in, it can’t find the file:

error: Text: can’t find file HD:/blah/text.txt – when that is the correct location.

Any pointers anyone?


Apr 13 2008 | 7:55 pm

not "read" but "set"

max v2;
#N vpatcher 447 94 1047 494;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 287 212 33 196617 clear;
#P message 248 78 49 196617 border 1;
#P user textedit 248 235 348 285 32896 3 9;
#P user dropfile 248 101 365 168 1;
#P newex 248 191 62 196617 prepend set;
#P connect 3 0 1 0;
#P connect 1 0 0 0;
#P connect 4 0 2 0;
#P connect 0 0 2 0;
#P pop;

Apr 13 2008 | 8:05 pm

Thanks for the reply but that doesn’t solve it – I am trying to drag and drop a file to be directly loaded into the Text object. If I use "set" instead of "read", it doesn’t load the file, it just adds the file path string to my text objects memory…

Apr 13 2008 | 10:53 pm

dropfile -> prepend read -> text
works fine over here.

i know i’ve had some problems with harddrives that aren’t the root drive in the past, but without having a patch from you illustrating the problem, it’s all speculation.


Apr 13 2008 | 11:10 pm

Thanks for you help guys, I have solved it now – basically it was max being a plonker. All the time I’ve been trying to debug it, I had max open. After giving up and closing max, now coming back to it it works fine!

So yeah, it should be as easy as dropfile -> prepend read -> text and now it works (but didn’t before for unknown reason X).

I should have know because I have encountered this restart and it works stuff a handful of times before…


Apr 14 2008 | 12:11 am

Hold on, the problem is back and I know why. If I make a text file in text edit with the contents of "hello", and drop it into max it works, but I am dropping in .csv files from a spreadsheet (renamed .txt, which are plain text containing quotes and commas) and it wont work.

So its not a case of Text not finding stuff sometimes, it just says that it can’t find it when something goes wrong… (tut tut).

Interestingly when I remove the first line from the offending files which contains quotes ("…..") it miraculously works… I find it a bit crap that Text can’t read text with quotes but I now know just not to use quotes.


Viewing 6 posts - 1 through 6 (of 6 total)

Forums > MaxMSP