Forums > MaxMSP

hi (USB HID) SpaceNavigator acting weird in Windows

December 9, 2013 | 12:20 pm

I recently had to move a project from OSX to Windows, and am having a hell of a time with the change in drivers. I have all but one of them resolved, the SpaceNavigator, a 3D mouse.

In OSX using the hi node it reports values on channels 14-22. The the device is idle it reports values of zero, and any axis of movement sends +/- 1 to 512. Works great, I’ve used it a lot over the past few years.

On Windows8-64, however, its a very different story. At first the device reported nothing at all, so I installed the manufacturer’s drivers. The device works as advertised within windows and the applications it has specific profiles for. Unfortunately the hi node in MAX is sending what appear to be infinite incremental values in the positive or negative direction when an axes is moved. i.e. when you move an axes is starts counting positive or negative, when you release, the value stays, and if you move it again it continues counting from the same value. Whats even worse is I have seemingly no way to discern which channel is which axes, as the slightest touch sets almost all of them in motion. It behaves this way no matter what control profile is active in the manufacturer’s software, even on profiles that have all the axes disabled.

I tried removing the driver, reinstalling the driver, uninstalling the manufacturer’s software, different USB ports, reinstalling MAX, and more, but the results are always the same. If its reporting, its reporting in the above described manner. I suspected something might be wrong with the hi object on Windows, so I tried a few other USB HID devices that I frequently use. While they do report slightly different values on different channels, they ass behave essentially the same way as they do in OSX, stopping at a specific value when idle, and incrementing or decrementing to a limit when adjusted. This leads me to believe that theres nothing at all wrong with MAX. It must be something to do with the driver that is being used by Windows.

I contacted the manufacturer (3DConnexion) but essentially got a "nothings wrong with our stuff, it must be your IDE" in response. ()

Might anyone have some experience or suggestions as to whats going on here? I’m quickly running our of time.


Viewing 1 post (of 1 total)

Forums > MaxMSP