Forums > MaxMSP

How to open BUILD window for patcher/project with NOMENU ?

Jul 27 2013 | 10:39 pm

I have a project where the main patcher (and all other patchers too) has "nomenu" flag.

Bad thing is, that using the "build standalone/application" from menu gives you a BUILD WINDOW with many options (scripts etc), but that’s inaccessable now for me, as i have NOMENU everywhere.

There is a function with same name "build standalone/application" in the project window too, but that one doesn’t open the BUILD WINDOW, it only asks for a filename and that’s it. Is that a bug?

How do I get the build window when using the project window / when unable to use the one in menu??

Aug 03 2013 | 7:05 am

please, can somebody help me with this?

Aug 03 2013 | 11:55 am

Not sure that I entirely understand this but can you create a mechanism which toggles the menu state, loadbang it to what you want at load but turn it off when you are building?

If that’s not it please send a stripped down example into support



Aug 03 2013 | 6:17 pm

i think this is what Andrew is alluding to–

-- Pasted Max Patch, click to expand. --


Aug 05 2013 | 3:40 am

Sure, I could create some special mechanisms to do what MAX is ABLE to do in one case when and not in the other. But isn’t this a bug?
Why do I get the build window when I click the "build …" function in one place (patcher) and not when I click it from project?

I attached detailed description of what I mean.

  1. bug_report


Aug 05 2013 | 4:21 am

So there’s two issues– one is the inconsistency between two different ways of building a standalone– (which means i never make standalones from the project window). I agree it’s strange and annoying. The other is the ‘menu’ issue, which is explained/solved via the ‘toggle mechanism’ answer.

Aug 05 2013 | 9:15 am

I agree that there should be more consistency. I’ll ticket this.

In the meantime though – you’re going have to hack your way through it.



Aug 05 2013 | 5:00 pm


Sep 02 2015 | 7:20 am

Hi there- I have the same problem except I don’t get a build window at all on either menu , i’ve tried using the "windows flag menu" but that doesnt change anything. Sorry to reopen an old thread with some probably simple questions..

Viewing 9 posts - 1 through 9 (of 9 total)

Forums > MaxMSP