Forums > Jitter

How to use Two PS3EYE in Jitter?

Nov 01 2010 | 11:39 pm


When I trying to connect multiple PS3EYE into a patch, the max crashes although I can see the jitter recognizes multiple webcam input.
I have no problem with using a eyesight on macbook pro and a ps3eye.


Nov 02 2010 | 8:04 am

Yes, I have same problem with two PS3Eyes. I assume that the macam driver is just not up to it and iSight would be using a different driver. Couldn’t seem to find a solution…

Nov 02 2010 | 4:35 pm

macam sys it has always supported multiple webcams. maybe it won’t support same type of webcams, or just for jitter?

Nov 03 2010 | 5:26 pm

Apple’s DV drivers do not. OS9 does not support multiple instances of a single device type. is this same for Snow Leopard? :S

Nov 10 2010 | 9:15 pm

This just popped up on another thread, there’s a ‘’:

Haven’t tried it yet, but will give it a go tomorrow.

Nov 25 2010 | 10:04 am

Finally got to trying this…doesn’t work. Open one camera in grab fine, then as soon as I open the other Max crashes. Not surprising as they both have the same ID in the menu, there’s a number after the name ‘PS3EYE’ but its the same for both. Like you say ‘multiple instances of a single device’. If only we could rename a USB device it might just work…

Nov 28 2010 | 1:00 pm

A friend of mine had the same problem(he uses 3 ps3eyes).
I think in the end he used multiple runtimes sending the images with to the main patch.
Perhaps he can chime in and give more info;)

It looks like jitter/quicktime problem since opening multiple cameras with macam app didn’t cause any problems.

Nov 30 2010 | 1:21 am

Runtime can handle 3 or more ps3eyes.
All 3 jit.qt.grab objects can be in one runtime patch, and matrices can be sent through to max.
I always get all tree cameras listed in device lists first, then open each camera, and at the end start metro for all of them. Any other order would crash runtime.
cameras will appear something like:
macam #0; Sony HD Eye for PS3…,
macam #1…
macam #2

I tried this on macmini 2.53 and mbp 3.06, it always worked the same way.

Strange, I had no problems with running other multiple usb cameras earlier. But PS3eye is somewhat more demanding. Probably is that ugly microphone box that causes the trouble.

Nov 30 2010 | 11:49 am

Interesting, starting uo with this order does indeed stop crashes, but in my device list both eyes are just called "Sony HD Eye for PS3 (SLEH 00201)". With both running its about 3 or more seconds between frames so its completely useless for motion tracking. I’m on a decent machine (MacPro 2x3Ghz Dual-Core Xeon, 4GB Ram), though I am on 10.4 if that has anything to do with it. There is a long cable run to the cameras with a powered hub in between which could be affecting things, will test it out when I get a chance.

Nov 30 2010 | 5:07 pm

Hm.. Cables didn’t matter in my case. I am using 5 meters long usb extensions, and have no delay. It is the same if the cables are different in length.
It is better if you plug cameras directly in to machine, you should try to skip that hub. Than you might solve indexation problem.
I was using hubs successfully with other cameras (without any extra power), but not with ps3eye.
It shouldn’t be your 10.4 that makes the problem,it is macam that handles all that camera things. Still, If you get the chance try testing it on 10.6, just to be sure.

Nov 30 2010 | 6:54 pm

Thanks for the feedback, sounds like wise words. Unfortunately its very hard to get another cable through the walls and ceiling up to where the cameras are but I can take them down and check it out before I start drilling holes!

Viewing 11 posts - 1 through 11 (of 11 total)

Forums > Jitter